pfBlockerNG-devel 2.2.5_17 + 2.4.4 (Uncaught Fatal Error)



  • Hello,

    I have run into an issue after I have installed pfBlockerNG-devel 2.25_17 on 2.4.4 pfsense. Before I installed the devel version I uninstalled the standard pfBlockerNG package (not setup) and rebooted.

    Crash report begins.  Anonymous machine information:
    
    amd64
    11.2-RELEASE-p3
    FreeBSD 11.2-RELEASE-p3 #17 e6b497fa0a3(RELENG_2_4_4): Thu Sep 20 09:04:45 EDT 2018     root@buildbot3:/crossbuild/ce-244/obj/amd64/WvDslnYb/crossbuild/ce-244/pfSense/tmp/FreeBSD-src/sys/pfSense
    
    Crash report details:
    
    PHP Errors:
    [03-Oct-2018 20:03:39 America/Los_Angeles] PHP Fatal error:  Uncaught Error: Cannot use string offset as an array in /usr/local/www/pfblockerng/pfblockerng_dnsbl.php:31
    Stack trace:
    #0 {main}
      thrown in /usr/local/www/pfblockerng/pfblockerng_dnsbl.php on line 31
    [03-Oct-2018 20:04:24 America/Los_Angeles] PHP Fatal error:  Uncaught Error: Cannot use string offset as an array in /usr/local/www/pfblockerng/pfblockerng_alerts.php:139
    Stack trace:
    #0 {main}
      thrown in /usr/local/www/pfblockerng/pfblockerng_alerts.php on line 139
    

    phBlockerNG is Enabled and saved on the General tab. Not sure what to do to further troubleshoot this.



  • Ok, to anyone else running into this issue you need to ensure the "Keep Settings" is unchecked in the General Tab and then uninstall the package. Once that is done reinstall the package and it should work.