Wildly out of control clock under vmware



  • I am using pfsense under vmware. The clock is running very fast 1000s of seconds per hour and the ntp deamon does not
    seam to correct this at all.

    Any clues on how to fix this?

    Thanks.
    .

    Chris



  • Are you using the VMware appliance, or have the Open-VM-Tools package installed?



  • Yes I am using the vmware tools version 102166_7_1.  pfsense version 1.2.2

    I just check my .vmx configuration it has

    tools.syncTime = "FALSE"

    should that be "TRUE"? I am running it in production so I don't want an unnecessary reboot.


    Chris



  • yeah set that to true



  • No joy. Setting that parameter to TRUE did not give an noticeable improvement in clock accuracy.



  • Disable any CPU throttling on your underlying platform.



  • How? Where?

    Is this a config option of vmware? or am I nice-ing vmware with out knowing it?



  • It's a setting either in the BIOS and/or in your operating system, I don't know if VMWare server can change this.



  • I checked the proccess table I am running this is what I got:
    command : ps -A -o pid,user,time,nice,args | grep vmware
    3192 root    00:00:00  0 /usr/bin/vmnet-natd -d /var/run/vmnet-natd-4.pid -m /var/run/vmnet-natd-4.mac -c /etc/vmware/vmnet4/nat/nat.conf
    3201 root    00:00:00  0 /usr/bin/vmnet-natd -d /var/run/vmnet-natd-8.pid -m /var/run/vmnet-natd-8.mac -c /etc/vmware/vmnet8/nat/nat.conf
    3207 root    00:05:38  0 /usr/sbin/vmware-serverd -s -d
    3245 root    00:00:02  0 /usr/lib/vmware-mui/apache/bin/httpd.vmware -DSSL -DSSL_ONLY -DGSX -d /usr/lib/vmware-mui/apache
    3251 wwwrun  00:01:34  0 /usr/lib/vmware-mui/apache/bin/httpd.vmware -DSSL -DSSL_ONLY -DGSX -d /usr/lib/vmware-mui/apache
    3256 wwwrun  00:00:00  0 /usr/lib/vmware-mui/apache/bin/httpd.vmware -DSSL -DSSL_ONLY -DGSX -d /usr/lib/vmware-mui/apache
    3394 root    00:00:00  0 /usr/bin/vmnet-dhcpd -cf /etc/vmware/vmnet4/dhcpd/dhcpd.conf -lf /etc/vmware/vmnet4/dhcpd/dhcpd.leases -pf /var/run/vmnet-dhcpd-vmnet4.pid vmnet4
    10825 admin    01:14:55 -10 /usr/lib/vmware/bin/vmware-vmx -C /home/admin/vmware/pfSence/pfSence.vmx -@ ""
    12725 admin    00:00:00  0 grep vmware

    -10 is the lowest (best) priority on the system at the moment. So I do not think I am starving the vmware proccess. Should I lower the nice-ness of vmware-serverd too?



  • VMWare assumes (for the purposes of time keeping) that the processor runs at a fixed speed, that has nothing to do with nice or anything else.  You need to ensure that the processor does run at that fixed speed - hence disabling processor performance management in hardware (or OS).

    Intel call theirs SpeedStep, AMD call it Cool 'n' Quiet.  It's also known as performance states (and a few other things).

    Step one - look in your BIOS for anything called SpeedStep or Cool 'n' Quiet - disable it.

    Step two - what version of Linux/BSD are you running?



  • Ahh ok. So I will have to reboot to try this solution.
    (to check the bios)

    I am running OpenSuse 11.0 on the box in question. 2.6.25 kernel. an intel x86_64 .

    I just checked the "my computer" window in KDE, it said that the cpu speed was changing. So this could be the problem.

    It will be a while for me to try this as the server is in production and I do not want to take it down for 20-30+ min with out
    notice.


Log in to reply