Probleme squid reverse collabora online



  • Bonjour,
    J'ai installé dernièrement l'application collabora online dans nextcloud tout fonctionne correctement lorsque je suis à l'intérieur de mon LAN (pas de passage par le proxy reverse) par contre depuis l'extérieur collabora se lance mais bloque sur une requette wopi car la destination est une adresse interne à la dmz.

    quand je suis depuis mon LAN pas de souci car l'adresse passe du LAN à la DMZ sans passer par le reverse proxy squid.

    auriez vous une idée ?? j'ai bien configuré collabora avec un apache proxy dessus comme demandé ( mais mon interrogation est sur la cascade de reverse proxy ?,)

    sur le forum je n'ai pas trouvé d'idée.

    Merci d'avance
    cordialement
    Eric



  • Je ne comprends rien à ton explication. J'ai pourtant relu plusieurs fois mais je n'ai aucune idée de ton réseau, de ce à quoi sert la DMZ, de quelles sont les IP.
    Et en plus, je peux me tromper mais j'ai l'impression que tu confonds allègrement les aspects proxy et reverse proxy.



  • Totalement obscure. Pfsense n'ai pas mentionné on se demande même ce que fait ce message ici.



  • Bonjour,
    excusez moi de l’incompréhension je vais essayer d’être plus précis.

    un réseau avec pfsense 2.4.3 et une DMZ, un LAN et un WAN (trois pattes différentes) réseau ip publique (WAN) LAN en 172.16.0.0 et DMZ en 192.168.0.0. squid reverse proxy sur le pfsense tout ok plusieurs site en http et https dessus.
    dans la dmz j'ai monté un nextcloud en 192.168.0.1 (avec certificat letsencrypt ok) puis configuré apache en proxy comme il le demande dans la documentation de collabora code. Collabora est aussi dans la dmz sur la même machine que nextcloud.

    j'ai ajouté un docker en 127.0.0.1 collabora comme précisé dans la documentation de collabora.

    je m'explique : lorsque je suis depuis ma patte lan tout fonctionne correctement car j'attaque mon nextcloud et collabora directement sans passer par le proxy squid de pfsense, nextcloud et collabora fonctionnent. Par contre lorsque que je viens depuis le WAN nextcloud pas de souci mais pour collabora cela commence à se charger puis la requette wopi est stoppée car celle-ci a l'adresse 192.168.0.1 et non pas l'adresse ip publique de mon WAN.

    j'ai essayé de mettre l'adresse publique dans mon dns ou le fichier hosts je n'ai accès plus rien sur collabora.

    Je vous remercie et espère avoir été plus clair
    Eric



  • il faut definir ces services dans ton reverse proxy, y compris collabra (je suppose que tu l'as fait) mais il ne faut pas que l'appel à wopi se fasse par son adresse IP: un fqdn est obligatoire.
    A défaut, l'autre option consiste à réécrire l'URL au niveau du reverse proxy.
    Pas sûr que ce soit simple avec Squid.
    Tu peux faire ça avec Nginx en revanche mais pas avec pfSense 😉