2 Exchange Server und 2 Domains hinter einer public IP



  • Hallo Leute,

    ich versuche HAProxy zu konfigurieren. Bisher leider erfolglos.

    Wir haben zwei Domains, einen Internetanschluss und 2 Exchange Server (je einen für jede Domain).

    Wir nutzen pfSense 2.4.4 und HAProxy 1.7.11.

    Hier die Konfiguration:

    # Automaticaly generated, dont edit manually.
    # Generated on: 2018-10-04 21:47
    global
    	maxconn			1000
    	stats socket /tmp/haproxy.socket level admin 
    	uid			80
    	gid			80
    	nbproc			1
    	hard-stop-after		15m
    	chroot				/tmp/haproxy_chroot
    	daemon
    	server-state-file /tmp/haproxy_server_state
    
    listen HAProxyLocalStats
    	bind 127.0.0.1:2200 name localstats
    	mode http
    	stats enable
    	stats refresh 10
    	stats admin if TRUE
    	stats show-legends
    	stats uri /haproxy/haproxy_stats.php?haproxystats=1
    	timeout client 5000
    	timeout connect 5000
    	timeout server 5000
    
    frontend Frontend-2-https
    	bind			xxx.xxx.xxx.xxx:443 name xxx.xxx.xxx.xxx:443   
    	mode			tcp
    	log			global
    	option			socket-stats
    	maxconn			1000
    	timeout client		30000
    	tcp-request inspect-delay	5s
    	acl			SxxxxOutlookSNI	req.ssl_sni -m sub -i sxxxxxx.de
    	acl			WxxxxOutlookSNI	req.ssl_sni -m sub -i wxxxxxx.de
    	tcp-request content accept if { req.ssl_hello_type 1 }
    	use_backend Sxxxx_ipvANY  if  SxxxxOutlookSNI 
    	use_backend Wxxxx_ipvANY  if  WxxxxOutlookSNI 
    
    backend Sxxxx_ipvANY
    	mode			tcp
    	id			100
    	log			global
    	timeout connect		30000
    	timeout server		30000
    	retries			3
    	server			Sxxxx 192.168.2.6:443 id 101 ssl  verify none 
    
    backend Wxxxx_ipvANY
    	mode			tcp
    	id			102
    	log			global
    	stick-table type ip size 50k expire 10m
    	stick on src
    	timeout connect		30000
    	timeout server		30000
    	retries			3
    	server			Wxxxx 192.168.2.2:443 id 103 ssl  verify none
    

    Leider bekomme ich vom Browser folgenden Fehler:
    ERR_SSL_PROTOCOL_ERROR

    HAProxy lauscht auf WAN:443. Dies habe ich schon geprüft.

    Hat jemand eine Idee woran es hängt? Vielen Dank.



  • @idelak
    Disable the ssl checkbox on the server line?



  • I spend a whole day to make it work.
    Thank you. It works now :)