Script implementar WPAD falla en 2.4.4



  • Por mucho tiempo usé el script que creó Javier Castañón para implementar WPAD en pfSense:
    Mywpad.php GUI script para configurar WPAD en pfSense 2.3.x
    Ahorra mucho tiempo al hacer los pasos de configuración de manera automática. Lastimosamente en la versión 2.4.4 se usa PHP 7 y se produce un error fatal que impide la carga de la página. Espero que el desarrollador pueda adaptar el script para esta versión nueva.
    Gracias



  • Este es el error:

    HP Fatal error: Uncaught Error: Cannot use string offset as an array in /usr/local/www/mywpad.php:347



  • Hola muy buenas compa,has probado en hacer el script tu mismo? en la documentacion hay mucha info para poder hacerlo y tambien en el canal de youtube de periko hay un video sobre WPAD muy bien explicado,saludos.