Как объединить две подсети?



  • День добрый.
    Есть две сети (192.168.1.0/24 и 192.168.20.0/24). Включены в две разные сетевушки на Pfsense: LAN1 (192.168.1.1) и LAN2 (192.168.20.1)
    Что нужно сделать что бы компы из одной сети видели другую и наоборот?
    Пробовал прописать правила, но ничего не получается. Узлы сетей ни в какую не хотят видеть друг друга.
    Подскажите как и что надо сделать для этого?
    Спасибо.



  • Да в общем то никаких премудростей тут нет, в фаерволе прописываете разрешающее правило в LAN1 в LAN2 и в LAN2 в LAN1 в общем то и все.



  • Да я тоже так думал. Бьюсь уже второй день.
    Вот делал даже вот так:
    https://b.radikal.ru/b05/1810/86/7a9999b07f1c.jpg
    https://b.radikal.ru/b06/1810/dc/8a6c4479a30f.jpg
    Пробовал разные варианты. Все никак. узлы не пингуются и не видятся в упор :(



  • @crazymax
    Добрый день
    А не пингуются по IP адресу или по имени хоста ?
    И еще вопрос ,
    с сети 192.168.1.0 пингуется 192.168.20.1
    и наоборот ?



  • У Вас в правилах указан TCP, а пинги ICMP. Разрешите для начала все протоколы.



  • @buch На обеих картинках снизу правила , разрешающие все протоколы. Однако у ТС пинги не ходят .



  • внизу правила для всех протоколов в одну сторону - из LAN2



  • @buch Это для lan2
    0_1539174088527_bb83b8a1-0c42-4158-92fa-e6f6edcf6777-image.png
    А это для Lan
    0_1539174117600_65201f14-d338-4a1b-a939-f069648c6005-image.png



  • Я пробовал ставить "все протоколы". Не помогает. Мало того, в одной сети есть устройства с вебмордами. Доступа к ним нет тоже :(



  • @konstanti
    Не пингуются по IP
    Из каждой сети оба адреса сетевух pfsens (192.168.1.1 и 192.168.20.1) пингуются без проблем.
    И как я написал выше, нет доступа даже по http



  • @crazymax
    И пингуется , к примеру , 192.168.1.1 из 192.168.20.0/24 с любого хоста
    и наоборот
    А какие операционки стоят на хостах ??? Нет ли антивирусов ?
    я



  • @konstanti
    192.168.1.1 из 192.168.20.0/24 пингуется.
    Операционки разные. Не в этом дело. Принтера с вебмордами, zabbix и прочее не видится из другой сети. Из своей - без проблем.



  • @crazymax NAT случайно не включен ? Tcpdump не включали для анализа ?



  • @konstanti
    NAT включен. Pfsense только поставил и начал разбираться. Все по дефолту, кроме правил. Просто первая же задача в тупик и поставила :(
    Его просто выключить "Disable Outbound NAT "? Или в Mapping чего-то надо добавить/убрать?
    Просто выключить не помогло.
    Tcpdump не вижу где это?
    И еще, извиняюсь что ввел в заблуждение,
    192.168.1.1 из 192.168.20.0/24 пингуется, а вот 192.168.20.1 из 192.168.1.0/24 нет. Может тут собака порылась?



  • @crazymax said in Как объединить две подсети?:

    День добрый.
    Есть две сети (192.168.1.0/24 и 192.168.20.0/24). Включены в две разные сетевушки на Pfsense: LAN1 (192.168.1.1) и LAN2 (192.168.20.1)
    Что нужно сделать что бы компы из одной сети видели другую и наоборот?
    Пробовал прописать правила, но ничего не получается. Узлы сетей ни в какую не хотят видеть друг друга.
    Подскажите как и что надо сделать для этого?
    Спасибо.

    Попробуйте создать такое правило на интерфейсе LAN 1

    IPv4 any LAN1 net * LAN2 net * * none LAN 1 >>LAN 2

    Правило должно быть в самом верху (первым)

    ============================================================

    И анологичное(подобное) на интерфейсе LAN 2

    IPv4 any LAN2 net * LAN1 net * * none LAN2 >>LAN 1

    Правило тоже должно быть в самом верху)

    И в дополнение если у вас Multiwan то gatawey в правилах должен быть по дефолту



  • @oleg1969
    Сделал
    1_1539176046703_lan2.jpg 0_1539176046702_lan1.jpg

    Без перемен :(
    Картина такая:
    192.168.1.1 из 192.168.20.0/24 пингуется
    192.168.20.1 из 192.168.1.0/24 не пингуется.

    Устройства с вэбмордами в сети 192.168.1.0/24 из 192.168.20.0/24 не видны.



  • @crazymax нужно смотреть tcpdump
    куда доходят пакеты и где теряются
    попробуйте для начала запустить его на интерфейсе 192.168.20.1 (протокол icmp) в идеале из консоли



  • Всем ОГРОМНОЕ спасибо. Разобрался... аж стыдно писать в чем была проблема :)
    Поскольку это не с нуля сеть, а переход с D-Linka, я не поменял адрес шлюза на клиентских устройствах :(
    Поставил правильный шлюз и все взлетело.
    Еще раз всем спасибо.