How to hide ipv6 entries in firewall logs?



  • Hello,

    I frequently look at Status / System Logs / Firewall. There are many ipv6 logs there. How can I hide them and show only ipv4 logs? And by the way, there is not an option to select which interfaces logs to show (WAN or LAN).



  • There is a line above the log data that says Advanced Log Filter that when expanded allows you to filter the logs in a variety of ways. You can enter a specific interface, look for certain ports or IP addresses, and enter strings (I think some fields might even accept regex).



  • This post is deleted!


  • Thank you very much.


  • Galactic Empire

    @virgiliomi said in How to hide ipv6 entries in firewall logs?:

    e is a line above the log data that says Advanced Log Filter that when expanded allows you to filter the logs in a variety of ways. You can enter a specific interface, look for certain ports or IP addresses, and enter strings (I think some fields might even accept regex).

    If you don't run IPv6 you could always create two drop rules at the bottom of your interface rules and don't log IPv6.

    0_1539346837017_Screenshot 2018-10-12 at 13.18.51.png



  • We don't use IPv6 in our network. We have this same rule in our pfsense. But I see these kind of logs in firewall logs.

    0_1539351009552_1.jpg


  • Galactic Empire

    Try changing the IPv6 src to any rather than LAN2 net.



  • @nogbadthebad said in How to hide ipv6 entries in firewall logs?:

    Try changing the IPv6 src to any rather than LAN2 net.

    This will likely fix it as it’s likely that you’re seeing the logs with multicast addresses, which aren’t LAN2 addresses.



  • Which one should I choose?

    0_1539351576397_1.jpg


  • Galactic Empire

    Any



  • I did as you said. But it didn't help. There are ipv6 logs running in firewall logs.
    Do I always have to choose "any" as source address by default?
    0_1539442611590_Screenshot from 2018-10-13 18-54-52.png



  • Yes, you’ll need to choose “any” as the source. Link-local (fe80:) and multicast IPv6 addresses don’t meet the “LAN2 net” address range. That’s why those addresses still show up in the firewall logs for the LAN2 interface.



  • I have chosen "any" as the source. I am attaching photos. Please have a look and let me know where I am wrong. By the way, I have unchecked "Allow IPv6" and checked "Prefer IPv4 over IPv6" in System / Advanced / Networking.

    0_1539586327369_1.jpg
    0_1539586333424_2.jpg
    0_1539586339149_3.jpg
    0_1539586344646_4.jpg


  • Galactic Empire

    Try doing the same from your other LAN interfaces.



  • Other interfaces has the same settings as others.
    I have WAN, LAN, LAN2, LAN3, OPENVPN, IPSEC.


  • Galactic Empire

    Hmm should work, have you killed the firewall states ?

    There aren't any hits against that firewall rule.


  • Rebel Alliance Global Moderator

    Doesn't matter what you put on your interfaces since its being blocked by the BLOCK ALL IPv6 rule you have enabled.

    0_1539597335020_blockALL.png

    0_1539597274368_blockallIPv6.png

    That is what is logging it - I do not believe you can enable that and not log off the top of my head.. if you don't want any logging blocked ipv6.. Just undo that setting.. Then don't allow it.. If your seeing stuff being blocked by the default log, then as stated create an IPv6 block rule for any IPv6 and don't log it.


  • Galactic Empire

    @johnpoz said in How to hide ipv6 entries in firewall logs?:

    That is what is logging it - I do not believe you can enable that and not log off the top of my head.. if you don't want any logging blocked ipv6.. Just undo that setting.. Then don't allow it.. If your seeing stuff being blocked by the default log, then as stated create an IPv6 block rule for any IPv6 and don't log it

    Drat didn't notice 1000000003, good spot John


  • Rebel Alliance Global Moderator

    @emammadov said in How to hide ipv6 entries in firewall logs?:

    We don't use IPv6 in our network.

    Do you control all the devices in your network? If so and your not wanting to use IPv6 I would actually try and turn it off at the devices. Windows is one chatty kathy that when it comes to noise - out of the box it just doubles all that noise via IPv6. And if your not using it - its pointless to leave all that noise out there..

    Simple reg entry or can be disabled in group policy.. Prob a good thing to see the noise so you can turn it off at the source ;)

    Linux is not anywhere as chatty... You prob won't hear a peep out of it if you don't have IPv6 at the router.

    547 is dhcpv6 - and 5355 is LLMNR, NOISE!!! if your not actually using it. You for sure can turn that off on ipv6.. And that screams windows clients ;)



  • I have checked "Allow IPv6", now I see this entries in firewall logs:

    Oct 15 14:08:40 WAN Block ULA networks from WAN block fc00::/7 (12000) 10.128.0.2 my public ip ICMP

    You said: if you don't want any logging blocked ipv6.. Just undo that setting.. Then don't allow it

    It means, I have to check "Allow IPv6" and then uncheck "Allow IPv6"? I have rules in interfaces that block ipv6.


  • Galactic Empire

    @emammadov said in How to hide ipv6 entries in firewall logs?:

    I have checked "Allow IPv6", now I see this entries in firewall logs:
    Oct 15 14:08:40 WAN Block ULA networks from WAN block fc00::/7 (12000) 10.128.0.2 my public ip ICMP
    You said: if you don't want any logging blocked ipv6.. Just undo that setting.. Then don't allow it
    It means, I have to check "Allow IPv6" and then uncheck "Allow IPv6"? I have rules in interfaces that block ipv6.

    Status -> System Logs -> Settings

    0_1539598961397_Screenshot 2018-10-15 at 11.22.22.png

    Guessing you had these ticked.


  • Rebel Alliance Global Moderator

    @emammadov said in How to hide ipv6 entries in firewall logs?:

    Then don't allow it

    If you do not have Allow rules then ALL is blocked - all interfaces have default deny both ipv6 and Ipv4.. not allowed... Only things that are allowed are hidden like dhcp if you enable dhcp on that interface.. This is just common sense rules because most users are idiots ;) And if they enabled dhcp and it didn't work they would have a no clue how to create the firewall rules ;) I personally think they should be shown.. But that is another topic.

    All interfaces will block traffic if not allowed... Not blocking IPv6 just removes that stupid rule :) Then as long as you don't allow it or you put in a block rule on your own.. And don't log then no iPv6 will be allowed or working..

    But again - vs just not logging it at the the firewall doesn't remove the NOISE.. your just not logging it - still traffic on your network for no reason if your not using... Why should a client continue to bang its head asking for dhcpv6 if you don't have any dhcpv6 running. Why should it bother with LLMNR if nobody is using it?

    Security 101 is do not enable protocols and services your not using. If your NOT using ipv6 - then why should it be enabled and why should it be sending out just craptastic amounts of noise? Turn it off at the client level if you have control of the clients and they allow for it. You could for sure run into some shitty iot device that doesn't allow you to disable something like ipv6.. But from that traffic I would guess windows boxes..



  • Thank you. Now there are no ipv6 logs.

    0_1539601687040_1.jpg