Help with starting to use HAProxy - LB ip address is not delegated to virtual machines

  • Hi,
    I am total beginner for HAProxy so please any advice will be much useful.
    I have two virtual machines on Microsoft Azure.
    They are in virtual network, and they have private IP addresses and
    I created new Network interface on Microsoft Azure in the same virtual network with IP address
    Of course this is not delegated to any virtual machines.

    Name of interface is : lb.oozie.local, private IP address

    I added in /etc/hosts on .4 and .5 lb.oozie.local

    I installed haproxy on both machines 4 and 5.
    haconfig file is the following:

    log /dev/log local0
    log /dev/log local1 notice
    chroot /var/lib/haproxy

        stats timeout 30s
        #user haproxy
        #group haproxy
        # Default SSL material locations
        ca-base /etc/ssl/certs
        crt-base /etc/ssl/private
        # Default ciphers to use on SSL-enabled listening sockets.
        # For more information, see ciphers(1SSL).
        ssl-default-bind-ciphers kEECDH+aRSA+AES:kRSA+AES:+AES256:RC4-SHA:!kEDH:!LOW:!EXP:!MD5:!aNULL:!eNULL

    log global
    mode http
    option httplog
    option dontlognull
    timeout connect 5000
    timeout client 50000
    timeout server 50000

    frontend localnodes
    bind lb.oozie.local:80
    mode http
    default_backend nodes

    backend nodes
    mode http
    balance roundrobin
    option forwardfor
    http-request set-header X-Forwarded-Port %[dst_port]
    http-request add-header X-Forwarded-Proto https if { ssl_fc }
    option httpchk HEAD / HTTP/1.1\r\nHost:localhost
    server oozie1 check
    server oozie2 check

    listen stats lb.oozie.local:1936
    stats enable
    stats uri /haproxy?stats

    I did also:
    sudo service haproxy restart

    Redirecting to /bin/systemctl restart haproxy.service

    Validation returns that haproxy is valid:
    haproxy -f /etc/haproxy/haproxy.cfg -c

    [WARNING] 284/112531 (110051) : config : frontend ‘GLOBAL’ has no ‘bind’ directive. Please declare it as a backend if this was intended.
    Configuration file is valid

    As I understood my servers should get the ip address (

    I try from and ping to

    but on both servers I am getting it is not recognized.

    PING ( 56(84) bytes of data.
    From icmp_seq=1 Destination Host Unreachable
    From icmp_seq=2 Destination Host Unreachable

    Also if it is relevant:

    i installed keepalived mechanism
    I did not set public IP address for Load Balancer address, it has only private IP, because service is invoked directly from servers and

    please help.
    Thank you in advance,

Log in to reply