Whitelist ports in pfBlockerNG-devel 2.2.5_17?



  • Hey there guys, finally trying out pfblockerng in general, and getting started with the devel version since it has more nifty features! One thing I noticed is it's blocking a lot of IP's already (WOOT!) but there's... one port in particular I want to whitelist from ALL IP's. Is it possible to do a whitelist from all IP's on a port?

    As far as I understand, the way to do it would be in pfBlockerNG > IP > IPv4 > Add, but not sure what to enter for 'Source' in the IPv4 Source Definitions. Let me know if I'm on the right track!


  • Moderator

    @mattgphoto said in Whitelist ports in pfBlockerNG-devel 2.2.5_17?:

    far as I understand, the way to do it would be in pfBlockerNG > IP > IPv4 > Add, but not sure what to enter for 'Source' in the IPv4 Source Definitions. Let me know if I'm on the right track!

    If you want to whitelist inbound (WAN), then yes you are in the right place, but look at adding a Ports Alias in pfSense first, and then reference that in the Adv. Inbound Rule settings.



  • Fantastic response time! Thank you! Looks like I'm almost sorted, only thing is what to put for the Header/Label? I get that it has to be unique, but anything I try, I get 'Failed download(s)'. Is there something in particular I have to use here? One of the names of an existing rules in the widget? Or?


  • Moderator

    @mattgphoto said in Whitelist ports in pfBlockerNG-devel 2.2.5_17?:

    Fantastic response time! Thank you!

    YW!

    Looks like I'm almost sorted, only thing is what to put for the Header/Label? I get that it has to be unique, but anything I try, I get 'Failed download(s)'. Is there something in particular I have to use here? One of the names of an existing rules in the widget? Or?

    If you are added these IPs to the custom list at the bottom, then you don't need to put anything in the Table above... Just leave it all blank (default). You would only enter a Header/Label, if there is a URL associated to that.



  • Got it saved correctly, however am still seeing blocks. Here's what I've done:

    1. Added alias for port under Firewall > Aliases > Ports
    2. In Firewall > pfBlockerNG > IP > IPv4, created a Source
    3. Go to pfBlockerNG > Update > Run (Or wait for cron event).
    4. Result

  • Moderator

    @mattgphoto

    Check the "Rule Order" option in the General/IP Tab... and ensure that the "permit" rules are above the blocked rules... Also check the WAN Firewall tab.



  • Mmm, good point. Had it set to pfB block/reject/all other rules. Now is the status:

    1. General > IP Tab
    2. Firewall > Rules > WAN tab (It's at the top of my WAN rules now)

    And still seeing pfB rules blocking the port from the countries in rules... here



  • @bbcan177 Something else I actually came across as well, is it looks like pfBlockerNG is filtering the port based on a different rule? (A different name shows up): here