Hostnamen werden über DNS nicht aufgelöst



  • Hallo alle zusmmen,
    ich habe ein Problem mit meiner pfSense mit der DNS-Auflösung.
    Seit ein paar Tagen habe ich mir auf einem Windows Server 2016 eine AD und einen DNS-Service installiert.
    Nun sollen alle Geräte über den neuen DNS-Server ihre Namensauflösung nach außen wie auch intern durchführung.
    Die pfSense ist auch mein DHCP-Server. Im DHCP habe ich als Namenserver1 den Windows Server angegeben.
    Schaue ich jetzt bei einem Gerät in die Netzwerkeinstellungen, sehe ich, dass der Windows Server nun für die DNS-Auflösungen zuständig ist.
    In meiner pfSense ist default aktuell noch der DNS Forwader aktiviert.
    Alle Geräte / Systeme können ins Internet auflösen.

    Nun wollte ich in meine AD mein FreeNAS und mein esxi einhängen, musste jedoch feststellen, das die Hostnamen bei einem Ping nicht aufgelöst werden können.
    Beispiel: freenas.maxmustermann.de -> Kann nicht aufgelöst werden (interner Name)
    192.168.178.30 -> Ping läuft durch

    Nun habe ich ein Windows Laptop schon in der AD. Das Einbinden ging ohne Probleme. Ping ich diesen an, wird er sauber aufgelöst. Das Laptop ist das einzige Gerät, bei dem aktuell die Namensauflösung funktioniert und ich weiß nicht warum. Ich finde meinen Denkfehler nicht, warum die anderen sich nicht auflösen lassen.
    Bei dem FreeNAS- und esxi-System ist ebenfalls der neue DNS-Server eingetragen worden und die Systeme neu gestartet worden. Jedoch lassen sie sich einfach nicht auflösen.

    Hier einmal mein Netzwerkaufbau:

    Telekom
          |
          |
    FritzBox 7490 (192.168.5.1)
          |
    ML350p WAN Port
          |
    esxi vmx1  ----- pfSense FW
    |
    esxi vmx2  ----- pfSense FW | DHCP (192.168.178.1)
    |
    VM-Netz + Switch
    |
    |
    ----------------------------------------------------------------------- 
    |              |                |                           |
    etc.       Laptop               AP1                   AD+ DNS-Server
    

    Hat jemand eine Idee oder einen Tipp für mich, wo hier mein Denkfehler sein kann?



  • Hallo,

    hast du die Hostnamen auch im DNS eingetragen? Von selbst machen die Geräte das wohl nicht im Gegensatz zu einem Windows-Gerät.

    Grüße



  • Den Wald vor lauter Bäumen nicht mehr sehen 😌
    Ok das wars. Ich hab mich schon gewundert, warum sich die Systeme dort nicht melden.
    Ok, hätte ich nicht gedacht. Danke :)