RDP/SSH disconnection with squid + icmp passthrough issue



  • Hi,

    I've configured Pfsense with Squid (Transparent Mode + SSL splice all) and captive portal on only one interface WAN

    (Computer) ==============> WAN (Pfsense) WAN ================> (router) 
    

    Pfsense sets as computer GW and Router sets as Pfsense GW

    So all traffic pass through Pfsense.

    Squid logs fine and captive portal login page is well displayed and works. I can connect.

    I'm currently encountering 2 issues.

    The first one is that every minute, I can see that a disconnection happens on my RDP, SSH connection. So on ssh, I have to reconnect every minute...

    The second "issue", is that when I enable captive portal, when I try to ping from my computer, request failed.
    When I disable Captive Portal (Squid still working) I receive ping response.

    I also notice that after several minutes of use, I need to suppress my connection in Status > Captive Portal because I receive web page error, more and more, until I restart.

    Thanks for your help and suggestion.

    Pfsense version: 2.4.4



  • Hi,

    I've made lot of tests but my issue still pending.

    What I've tried:

    -check "Clear invalid DF bits instead of dropping the packets"
    -Firewall Optimization options ==> Conservative
    -Check "Disables the PF scrubbing option which can sometimes interfere with NFS traffic."
    -Check "By pass firewall rules for traffic on the same interface"
    -Check "Do not kill connections when schedule expires"
    -Check "Disable Gateway Monitoring"
    -Uncheck "Flush all states when a gateway goes down"

    Result:
    SSH connection still disconnect but after 15 minutes (instead of every 1 minute)
    RDP still disconnect
    Still can't ping through pfsense



  • Hi,

    It seems that issue was that we use only 1 NIC (as WAN)

    Since we've installed a second NIC and defined 1 NIC as WAN and the second as LAN, everything works well!

    Seb