Remote email server not contactable behind router



  • Hello,

    Apologies, am a novice at this.

    I have a SG-2440, it's on release 2.4.4. About a month ago, I noticed I wasnt able getting my emails from my remote server from MacHighway.com. At first I thought it was due to a bad password that was creating bad logins to their server and thus the IP being blocked. But this is not the case (this time).

    But if I VPN to my other location in London where I have another pfsense and subsequent OpenVPN, I can access the emails. And likewise other VPN services and also if I am not at home, I can access my emails. I've been onto MacHighway support and they say after submitting a Traceroute that it could be my ISP (Virgin Media). Been onto their support and they asked me to reset the router which is in modem mode, which I have done. What I did notice, if going directly through the VirginMedia cable modem with my laptop, I can access emails. But as soon as I enable Modem Mode, so that the pfsense box comes into service, then I still cannot access emails.

    Havent changed anything on the pfsense box for ages! Any clues where to look? Be a shame to factory reset and go back to configuring it?!

    Thanks.

    Ian



  • @digitalvt

    Try connecting to your email on port 587.

    My bet is that your ISP is blocking port 25.. Many do.



  • Hi, thanks for your reply.

    Am connecting via SSL and therefore the port is 993 and 465 (in and out).

    However, when I reset the VM cable modem, I had my laptop connected to directly via ethernet and when I rebooted it was able to download my emails. Then when set the modem to modem mode and this connect back to my network vi pfsense I wasn’t able to connect to the email server. Making me think that the pfsense is the problem, for whatever reason or other?

    Thanks.

    Ian



  • Are there any areas I can look at in my pfsense for blockages?



  • Can you post a screenshot of your LAN firewall rules? Or are they default and untouched??



  • Your very kind Mr Palmer,

    0_1543010333130_Screen Shot 2018-11-23 at 21.54.12.png

    Is this normal? I can't remember if thats deafult or added Rules? Thanks?



  • And from this LAN is where you are having the issue?



  • Yes, my internet is served via this



  • @digitalvt

    My next step would be a packet capture on both LAN and WAN..

    /diag_packet_capture.php

    See if the traffic is making it to either..



  • Hi,

    Just tried a packet capture (via a remote login as I'm at work), with the IP address of my email server, via the WAN I get packets captured but via the LAN, nothing!



  • @digitalvt said in Remote email server not contactable behind router:

    Your very kind Mr Palmer,

    0_1543010333130_Screen Shot 2018-11-23 at 21.54.12.png

    Is this normal? I can't remember if thats deafult or added Rules? Thanks?

    Rules on LAN are fine.
    I've the same and can reach the entire planet with these.
    So :
    Floating rules ?
    What is your WAN setup ?
    What is your DNS setup ?
    What packages are you using ? and if any packages : what happens when you disable them ?
    Also : save your config, and goto default, just setup a minimum, aka : your WAN. This will create a situation "all works".

    Btw : you can't reach your mail server using ports 993 and 465. Your mail server (supplier) has a web mail access - and that works ? Other "sites" that do not work ?



  • Thanks @gertjan,

    By a stroke of fluke, the other week I had my old SG-2220 floating about, which I had issues at my other site and thus replaced some 9months ago, admitteldy, I got myself in a flap and couldnt work out the issues thus just bought a replacement, so the 2220 had been sitting on a shelf and was about to package it up and it had been sold, but just checking it didnt have any personal info on it before despatch where I discovered it was working, firstly on the console so tried the ethernet port and was able to sign in.

    So for further laffs and giggles, I swopped it with my current SG-2440 and oddly enough, all my emails we coming in unhindered. Further updated with the current settings from my 2440 and all is good although I think it may be too much for it and it'll overheat, but we'll see.

    So could it be a hardware issue? With the SG-2440?? Literally, have all my network settings back and my emails now unhindered!