Timing issue with HyperV 2012R2 core



  • As per this thread >> https://forum.netgate.com/topic/138000/states/24

    2.3.5 works fine
    on my Dell PowerEdge T320, with dual networking ports built in.

    on upgrading (??) PFsense seems outwardly the same except that the traffic graphs are all skewed, and basically drawing random polygons rather than bars - like the time is jumping back and forward

    ALSO the states table is not cleaned automatically, and is filled with many hundreds of thousands of EXPIRED states.
    In 2.3.5 in 24 hours now, my states table is currently 130 entries, having reached 350 or so at peak - that's about what I'd expect. States display correctly on the dashboard.

    In 2.4.4 in 8 hours I get ~100 000 states, and I need to keep cleaning them with a 'pfctl -F states' every few hours.
    Also the firewall is buggy, dropping the internet connection every 10-15 minutes, and there is a CPU spike every ~10 seconds on the host server. States are always shown as 0 on the dashboard.

    I have disabled integration settings except for Operating System Shutdown, and Heartbeat.

    I have recreated my problem, by running a up a new VM on 2.3.5
    It works until I upgrade(??)

    The pain for me in this is that none of the packages will install unless I upgrade the base firmware first.
    I think I was on 2.4.3 originally before recent upgrade to 2.4.4 and I don't recall this issue until 2.4.4 was installed
    I can't find an ISO for that earlier version though
    https://atxfiles.pfsense.org/mirror/downloads/old/ gets me a '404 Forbidden' response.

    In my other thread, someone suggested that this might be the bug described here >> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=222126

    Seems like it to me, however the fix in that thread is to move to FreeBSD 12.0

    Any other ideas?



  • I keep Time Synchronization turned on and don't use pfSense as a time server.



  • Turning off PFsense as a time server proved more challenging than it should have been.

    But doing that, and setting time integration on worked well on the 2.3.5, but exactly the same issue of states not being cleared in my 2.4.4 still exists

    Gone back to 2.3.5 for now...still looking for ideas thanks



  • This isn't directly related to your probably but you probably don't want to use a VM as a time source as the VM and the Hyper-V host tend to fight about the time...possibly the cause of the jumps you mention.

    https://blogs.msdn.microsoft.com/virtual_pc_guy/2010/11/19/time-synchronization-in-hyper-v/
    "...the rate at which the time in a virtual machine drifts is affected by the total system load of the Hyper-V server. More virtual machines doing more stuff means time drifts faster."

    Aside from that 2.4.4 upgraded FreeBSD so you might look into the NIC settings on the host. I am not really pointing to you anything specific but maybe there were driver changes in FreeBSD related to Hyper-V NICs.

    Oh, how about this bit in the blog post for 2.4.4-p1? "Fixed issues with Hyper-V hn(4) network interfaces and IPv6 as well as issues with ALTQ."