pfSense 2.4.4-RELEASE-p1 is now available!



  • if you add ipv6 dns ip in DNS Server Settings, webgui will down .



  • Upgraded from cli, thanks so much. 😺

    Only I see small warning at the endo of kernel updating:

    Installed packages to be UPGRADED:
    pfSense-kernel-pfSense: 2.4.4 -> 2.4.4_1 [pfSense-core]
    Number of packages to be upgraded: 1
    [1/1] Upgrading pfSense-kernel-pfSense from 2.4.4 to 2.4.4_1...
    [1/1] Extracting pfSense-kernel-pfSense-2.4.4_1: .......... done
    ===> Keeping a copy of current kernel in /boot/kernel.old
    [: =: unexpected operator
    Removing unnecessary packages... done.
    Upgrade is complete. Rebooting in 10 seconds.

    Broadcast Message from root@pfSense.babiz
    (/dev/pts/0) at 19:29 CET...

    Upgrade is complete. Rebooting in 10 seconds.

    PC Engines APU2 - Netgate Device ID: 9acd80b985de5a8dab8d

    Regards.


  • Rebel Alliance Developer Netgate

    @babiz said in pfSense 2.4.4-RELEASE-p1 is now available!:

    [: =: unexpected operator

    That was a problem in the old kernel package, it's fixed in the newest one.



  • Not a "problem" so posting here....
    Where do we find this new sshguard GUI? I can't find it.
    The new autoconfig backup schedule is great to have, but despite reading the crontab man page I'm confused about the syntax. For a daily backup should it be 0---* in hours/day/month/dayofweek?


  • Rebel Alliance Developer Netgate

    @yon-0 said in pfSense 2.4.4-RELEASE-p1 is now available!:

    if you add ipv6 dns ip in DNS Server Settings, webgui will down .

    That is just not true. I have been running with this for years:
    0_1543864936632_Selection_108.jpg

    Re-read the first post and keep problems in separate threads, this is not a thread to report problems.


  • Rebel Alliance Developer Netgate

    @occamsrazor said in pfSense 2.4.4-RELEASE-p1 is now available!:

    Not a "problem" so posting here....
    Where do we find this new sshguard GUI? I can't find it.

    System > Advanced, Admin Access tab, Login Protection section.

    The new autoconfig backup schedule is great to have, but despite reading the crontab man page I'm confused about the syntax. For a daily backup should it be 0---* in hours/day/month/dayofweek?

    That would make a backup every day at midnight every day, yes.


  • LAYER 8 Global Moderator

    Ok - so I had tried to update my 4860 remote via vpn and it never came back.. Not sure exactly what happened... I am the first to say doing the update with all the packages and stuff I have running remote without some pre planning was not a good idea but pulling the trigger on both my 3100 remote installs went fine (no packages)..

    So when I got home I could not log in via console either.. But a simple power cycle its up and running and have internet again..

    As when you do this sort of update remote you should plan for issues is under statement.. My bad for sure - but a simple power cycle and all looks good. From what I can tell everything came back.. I will have to check logs and such - but as always you should follow the upgrade guidelines vs just clicking update.. Especially if device is remote..

    As of now I have no idea why it hung on the reboot.. I might never know? But again - I have run into such problems with all kinds of of very expensive 10k per device units, etc.. So remote updates are always a roll of the device.. Remote update should always include someone that can power cycle and out of band console access sort of stuff..

    But both of my 3100 clicky clicky - but they do not have all the packages my home box has installed..

    All looks good - and yes I had grabbed a copy of config before update, and worse case which I knew I could do when I got home I have 2.4.4 media and copy of the config.. My pulling the trigger remote was a at worse a couple of hours down time before I got there..

    I am just trying to be transparent on my experience.. This is for sure some sort of one off.. Prob related to my odd ball packages.. Something prob hung up the reboot..

    Wife is calling dinner - so look at logs later.



  • @jimp I have reported this issue very early, but it has not been fixed. Please pay attention to this

    https://forum.netgate.com/topic/135394/form-2-4-3-upgrade-2-4-4rc20180904-can-t-open-gateway-gui/37


  • Rebel Alliance Developer Netgate

    @yon-0 said in pfSense 2.4.4-RELEASE-p1 is now available!:

    @jimp I have reported this issue very early, but it has not been fixed. Please pay attention to this

    https://forum.netgate.com/topic/135394/form-2-4-3-upgrade-2-4-4rc20180904-can-t-open-gateway-gui/37

    See above, re: This is not a thread for reporting problems.

    Also, that is not the same as what you stated. You said:

    if you add ipv6 dns ip in DNS Server Settings, webgui will down

    But the linked thread says it requires you to be using OCSP stapling, which narrows the issue significantly and explains why it's working for the majority of users.



  • Installed on SG-2220 from pfsense 2.4.3p1 - all working here.
    Running packages: Snort, Squid
    Thanks netgate!!!


  • LAYER 8 Rebel Alliance

    I performed the 2.4.4-RELEASE-p1 Update remotely today for my three SG-3100 in production, everything worked very smooth. 😁
    Two devices coming from 2.4.4 and one from 2.4.3-p1
    Going for my two XG-7100 right after XMAS....way too much traffic on there 24/7 atm. 😬
    Thanks to the whole Netgate Team!

    -Rico



  • ran a online update and all seems good.

    I came from 2.4.2

    Nice to dhcp6 status screen fixed
    Nice to see I no longer need my custom patch for ntp status screen as base pfsense now allows it to wotih global noquery set.
    Nice to see my patch no longer needed for queue status screen refresh as base pfsense implemented custom refresh interval.

    Cpu utilisation is notably down I assume from the faster php 7.2.

    Also nice that unbound got updated, I was going to put a request in for it but was done anyway.



  • The "2.4.4-RELEASE-p2" thread is locked so I had to ask here: 2.4.4-p2 is still not available at https://www.pfsense.org/download/. I find this very unusual. When will 2.4.4-p2 be available for fresh install? Is there any issue with the fresh install? I upgraded without any issues on multiple machines. Thanks!


  • Rebel Alliance Developer Netgate

    This isn't the place to ask that, but I'll answer anyhow. We do not typically make CE installers for patch releases. -p1 was special because it had fixes for the installer that were needed for a large number of people.

    There won't be published -p2 installers, install -p1 and upgrade.


  • LAYER 8 Global Moderator

    one off installs for patches, p1, p2, p3, etc. etc. have never normal with pfsense. The release image, and then it updates to patches have been the normal since I can remember..

    That they released a p1 image would yeah mean something to do with the install part that was fixed. Thanks Jim for the info.



  • Thank you very much for clearing that out for me. Somehow I was under the wrong impression. You can clean-up my posts if you like.



  • The pfSense 2.4.4-p2 has been on my dashboard for some days then now it's disappeared:

    2.4.4-RELEASE-p1 (arm)
    built on Thu Nov 29 14:06:34 EST 2018
    FreeBSD 11.2-RELEASE-p4

    The system is on the latest version.
    Version information updated at Tue Jan 22 15:03:08 CET 2019

    Why?


  • LAYER 8 Global Moderator

    Could be all kinds of reasons.. If they would of pulled p2 then there would of been announcement.

    I am currently having some issues getting to pfsense.org download sites.. So maybe network problem somewhere, or server issue. example https://snapshots.pfsense.org/ I currently having a problem accessing.

    Well now I can get there - so maybe on my end, or maybe they cleared it up...


  • Rebel Alliance Moderator

    For all of you who missed the intel: They had a maintenance window at the NY datacenter from 2am to 5am this morning, so firmware/OS and package updates on that mirror were unavailable. Somehow they weren't available at all - I don't know why the other mirrors didn't kick in - but 99% sure that was the reason your dashboard wouldn't show the new version as the pkg update wasn't working at that time. @Summer try to re-check now, it should light ab right away. :)


  • Rebel Alliance Developer Netgate

    This thread is outdated and not for reporting problems. Start new threads for issues.

    Locking.


Locked