ntopng behind Squid Reverse Proxy - allow setting to set HTTP/HTTPS and port



  • Re: Ntopng not working behind HAProxy with SSL Offload
    I want to also echo the request in the above post. Please add the ability to choose what protocol HTTP / HTTPS and what port 3000/3001 ntopng runs with.
    Should be pretty straightforward to add to the config page to update ntopng.sh accordingly.
    Currently, the command runs with the options:

    -w 0 -W 3000
    

    I have edited it to be:

    -w 192.168.1.1:3000 -W 3001
    

    This way I can reverse proxy to port 3000 via HTTP locally.