disabling NAT redirect entry clears description in associated rule



  • Hi,

    Version 2.4.4_1 (latest stable as of today).

    Steps to reproduce:

    1. Firewall -> NAT -> Add -> Save -> Apply changes
    2. Firewall -> Rules -> find associated rule -> edit Description e.g. change from "NAT" to "NAT-BLAH" -> Save -> Apply changes
    3. Back to NAT, check redirect from point 1, "Rule NAT-BLAH" is showing under "Filter rule association".
    4. Edit -> Tick "Disable this rule" -> Save -> Apply changes
    5. Description resets back to default "NAT" under Firewall -> Rules
    6. Filter rule association resets back to default "Rule NAT" under Firewall -> NAT.

    Simply re-enabling the redirect entry or rule doesn't bring them back.

    Is it intended / known bug / bug candidate?

    Regards,
    Adam