FRR 0.2_4 installation broken with pfSense 2.4.4_1
The package doesn't like 2.4.4+, any possible workarounds? Downgrading this particular device is going to be rather annoying.
>>> Installing pfSense-pkg-frr... Updating pfSense-core repository catalogue... pfSense-core repository is up to date. Updating pfSense repository catalogue... pfSense repository is up to date. All repositories are up to date. Checking integrity... done (0 conflicting) The following 9 package(s) will be affected (of 0 checked): Installed packages to be REMOVED: pfSense-2.4.4_1 bind-tools-9.12.2P2 New packages to be INSTALLED: pfSense-pkg-frr: 0.2_4 [pfSense] frr5: 5.0.1 [pfSense] libssh: 0.7.6 [pfSense] rtrlib: 0.5.0 [pfSense] Installed packages to be DOWNGRADED: ndpi: 2.4.d20180830_1,1 -> 2.4.d20180830,1 [pfSense] json-c: 0.13.1 -> 0.13 [pfSense] Installed packages to be REINSTALLED: ntopng-3.6.d201800910,1 [pfSense] (needed shared library changed) Number of packages to be removed: 2 Number of packages to be installed: 4 Number of packages to be reinstalled: 1 Number of packages to be downgraded: 2 The operation will free 29 MiB. pkg-static: Cannot delete vital package: pfSense! pkg-static: If you are sure you want to remove pfSense, pkg-static: unset the 'vital' flag with: pkg set -v 0 pfSense Failed
jimp Rebel Alliance Developer Netgate
As I mentioned on the Redmine issue you made for this, it looks like a local issue with that system and not a general problem.
First, go to System > Update, Update Settings tab and make sure it's set to Latest stable version (2.4.x). Some of the versions for packages you're seeing there would only be on 2.4.5, not 2.4.4, so I suspect somehow it's looking at the snapshot repo and not the stable repo.
It's possible it landed in this incorrect state previously and you switched it back after doing something else like installing a package from the snapshots repo or some other repo like FreeBSD or a third party.
At one stage I did have the Dev repo selected, but I never updated the main system. However, it is quite possible I DID install a package during that time.
Do you have any specifics on which packages are the issue, and if so any ideas on how I could downgrade them to versions compatible with the stable repo?
Just to close this off. I reinstalled 2.4.4, frr installed fine. Upgraded to 2.4.4_1 and FRR appears to be working, although I am having GUI config issues adding a BGP neighbor, but I suspect that is separate as I've seen this happen previously.