Squid installation error and no GUI menu



  • The proxy package finishes (squid 0.4.44_7), but i have a PHP error returning to the dashboard and a warning also. The message is:

    Call to undefined function init_config_arr() in /usr/local/pkg/squid.inc on line 1775

    pfSense 2.4.3-RELEASE

    Installed packages:

    apcupsd 0.3.91_4
    openvpn-client-export 1.4.17_2

    Anyone with the same issue? Thank you, pfSensers!



  • Uninstall Squid and then Update pfSense to at least 2.4.4 after that reinstall Squid.



  • Yes, i had the same idea, but i saw a lot of issues about upgrades, and i believe that it's serious to think that a simple issue like this, just install Squid, requieres a system upgrade to get resolved. This is a completely fresh new installation, no other packages installed.

    Anyway, i'll try upgrading an reinstalling. I'll tell you later. Thank you for your time, Impatient!