OpenVPN - I can connect to pfSense GUI but not to my desktop computer



  • I have installed pfSense v2.4.4 and it appears to be working as it should. I subsequently installed OpenVPN. I believe it is working properly as well. When I take my laptop and go to another network I can connect with my home network via OpenVPN. I can enter the address of the pfSense Web GUI and read and write to it just like I was sitting at my desktop computer. However, using Windows 10 Pro's RDP, I cannot connect to my desktop computer. I get the message that RDP cannot find a computer by the name entered. When I enter the static address of my desktop computer into a browser, it searches forever and can't find anything. I've disabled the antivirus and firewall but the problem remains.

    I'd appreciate the advise of someone who has more knowledge than I!

    Thanks.


  • Rebel Alliance

    Did you try to ping the Client machine (with Windows firewall still disabled) to check traffic generally flow back and forth?
    Anything in the Firewall Logs?
    Maybe you can show your Firewall Rules with some screenshot.

    @johnsnyder said in OpenVPN - I can connect to pfSense GUI but not to my desktop computer:

    When I enter the static address of my desktop computer into a browser

    Try with the RDP Client (mstsc.exe).

    -Rico



  • I watched this Youtube video from Lawrence Systems: https://www.youtube.com/watch?v=7rQ-Tgt3L18

    At the 13 minute mark, he points out that one needs to add a line to the end of the config file created by VPN on the local computer being used to access the remote computer: redirect-gateway def1

    On another website it was suggested that I might need to add a line in the pfSense firewall to the file found under VPN/OpenVPN/Server. I edited the file and under Custom Options added: push "route 192.168.xxx.0 255.255.255.0"

    I'm not sure which of these two additions did the trick, but the net result is that now I can connect from a remote location both to the pfSense GUI and to my desktop computer.

    So ... problem solved!!