Problema con Internet en pfSense + Proxmox



  • Ola tengo un servidor dedicado con Proxmox instalado e instalé pfsense para gestionar la de de las VM pero no consigo tener Internet en ellas.

    El servidor tiene 3 tarjetas de red (1 fisica y 2 virtuales):

    • eth0: 94.xx.xx.xx

    • vmbr0: Puente a eh0

    • vmbr1: 10.0.0.1/24 Red Interna

    Me podríais ayudar con lo que tengo mal configurado

    Muchas Gracias!



  • Te recomiendo leer lo siguiente:
    Virtualizing pfSense with Proxmox

    Si te fijas, como mínimo te recomienda tengas 2 tarjetas de red físicas. En el ejemplo muestra 3 tarjetas físicas, una para WAN y dos para LAN.

    Como he estado haciendo pruebas con un equipo que tengo para virtualizar con Proxmox, sólo utilicé dos tarjetas de red, una para WAN (usando mi red interna con DHCP) y 1 para LAN.

    Luego creé dos interfaces virtuales, una para eno1 (en tu caso eth0) y otra para eno2 (digamos eth1). La primera interfaz virtual, hace referencia a eth0, configurada con una IP fija para la administración de Proxmox vmbr0 y la segunda interfaz virtual, haciendo referencia a eth1 sin IP vmbr1. Todo lo anterior en el nodo o raíz principal de proxmox.

    Luego, en el proceso de creación de pfSense, debes asignar ambas tarjetas virtuales pero en Model seleccionas VirIO (paravirtualized).

    En el proceso de configuración de pfSense, tomas vmbr0 para la WAN y vmbr1 para la LAN.

    Como te dije, se necesita como mínimo dos tarjetas de red, pero si realmente vas a administrar sólo los equipos virtuales que vas a crear en Proxmox, tal y como lo tenes debe funcionar pero en los equipos virtuales que se conecten a pfSense, debes configurarle la tarjeta de red a vmbr1.

    En caso que tengas algún sistema operativo viejo que no te permita el parámetro VirIO (paravirtualized), tendrás que probar algún modelo de tarjeta de red vieja para que trabaje. Eso te lo digo porque tengo un Windows XP y le tuve que poner en vmbr1 en Model una tarjeta Realtek RTL8139.

    Dicho lo anterior y si ves que el pfSense le reparte una IP en el rango que pusiste 10.0.0.X pero no tiene internet, quiere decir que pfSense SI está trabajando y en lo que debes revisar, es la configuración propia del pfSsense. Si le pusiste una IP fija en la parte WAN, asegurate que le tengas configurada la puerta de enlace (Gateway) y los DNSs.

    OJO y repito, tu configuración funciona siempre y cuando las conexiones sean al mismo equipo con esas tarjetas virtuales, pero en modo REAL y una red de equipos, debes tener SI o SI, dos tarjetas de red como mínimo.



  • Lo tengo asi de echo tengo una maquina de Windows 10 y un Ubuntu y les asigna IPs del rango 10.0.0.0 e incluso la puerta de enlance todo por DHCP pero sigo sin tener Internet.

    De que podría ser?

    Muchas Gracias...



  • Un saludos,

    yo lo tengo así como tu solo tengo una tarjeta de red física con el proxmox solo que como mi red es mediana de tamaño (de 100 a 200 usuarios) lo tube que dividir por vlan, el pfsense tiene la opción de colocar vlanes, claro tengo switch que me permite esto no se si tu tendrás uno a disposición y lo que hice fue colocarle dos tarjetas virtuales al pfsense en proxmox y asignarlas con sus respectivas vlan para la wan y la lan.



  • Si te fijas en lo que te escribí y si realmente lo tenes configurado así, entonces el problema NO es la LAN virtual para nada, sino la configuración del pfSense en la WAN o la LAN.

    Te escribo WAN o LAN, porque no sabría que escribirte porque no especificas nada y con solo escribir "lo tengo así", pues no se sabe exactamente que es o como lo configuraste.

    Si pusieras por ejemplo, mi WAN la configuré para que tomara la IP por DHCP o le puse una IP fija etc, ya uno podría comprender. De igual forma en la LAN, pero creo que todo está en la configuración de la WAN.

    Comprende que aquí se lee y no se ve, por lo que si no explicas lo que tenes, no se te va a poder orientar.



  • Eth0 (del proxmox) que es la ip publica, también debe estar en modo bridge.

    De esta forma las 3 interfaces del pfsense en el proxmox, son bridge.

    Y por supuesto, me imagino que tienes un /29 a nivel de ISP. En cado caso que seas un /30. Igual coloca eth0 como bridge, PERO SIN IP PUBLICA. la ip publica la seteas en el pfsense.

    Saludos


Log in to reply