Integração Pfsense 2.4.4 com Active Directory



  • Velho muito obrigado!

    Deu tudo certinho.. vc é o cara!! Valew!!!!



  • @rafamaximo2018 said in Integração Pfsense 2.4.4 com Active Directory:

    Velho muito obrigado!

    Deu tudo certinho.. vc é o cara!! Valew!!!!

    De nada...



  • O Markinho bom dia!

    Sem querer incomodar, mas fiz toda integração, com ad tudo certinho.

    Só que as páginas so dão acesso negado e quando fui olhar nos logs ele não esta autenticando com os usuários do ad.. Sabe o que pode ser... meu ad e um samba 4



  • @rafamaximo2018 Verifique na aba AUTHENTICATION se o NTLM esta assinalado...
    Informe os dados do seu servidor AD.

    alt text

    Após desça mais um pouco e veja se o "NTLMSSP Negotiate" está marcado (isso é muito importante para a integração) e coloque os dados do seu domínio. No meu caso é exsa.local e com 50 processos.

    alt text

    Depois vai no menu services e procure o Samba (AD) , esse item no meu foi incluído pelo Pf2AD.

    alt text

    Selecione e informe os dados do seu AD. O meu esquema é Windows 2008+ veja qual eh o seu.

    Esse procedimento vai incluir seu PFSense server no seu domínio. Verifique no seu domino pelo "Acitive directory Users and Computers" se o servidor do PFSense apareceu no seu Unidade Organizacional "Computers".

    Salve e faça testes.

    alt text



  • Apo MArkinho consegui novamente!

    Agora não consigo é a integração do mesmo com o squidguard... Ele não reconhece as regras de bloqueio... NO Squid sim ele reconhece mas preciso de criar grupos..

    Eu fiz assim:

    ldapusersearch ldap://192.168.20.1:3268/DC=domain,DC=com?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=adm,OU=Acesso,DC=dukar,DC=local))

    Está certo?



  • Boa noite pessoal,
    estava lendo o post de voces, e estou com uma duvida, fiz tudo que nosso amigo falou, ele so funciona com squid em modo transparente?



  • Oi Marcello bom dia!

    Não, funciona também em modo autenticado, mas não to conseguindo pois me parece que há algo na configuração do SquidGuard que não esta batendo.

    Por isso so consegui transparente, mandei as configurações acima para ver se alguem mais experiente consiga me ajudar...



  • @rafamaximo2018 said in Integração Pfsense 2.4.4 com Active Directory:

    ldapusersearch ldap://192.168.20.1:3268/DC=domain,DC=com?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=adm,OU=Acesso,DC=dukar,DC=local))

    Rafamaximo2018 você tem que ver 2 coisas pelo que percebi:

    Primeiro - Ver se a integração com o LDAP está correta:

    alt text

    Em "LDAP options" você tem que habilitar a integração e também ter uma conta no AD que fara a conexão com o Squidguard, que vai digitar ela no "LDAP DN", como na figura.

    Esse LDAP DN você pega o CN (Common Name) através do "ADSI Edit" (ferramenta do domínio para edição das OU's) isso dentro do seu servidor de domínio.

    Eu criei uma conta (não administradora) para fazer a integração "pfuser" e peguei o DN (Distinguished Name) dela.

    alt text

    Copie e cole no campo "LDAP DN" e depois digite a senha.
    Mark Strip NT DOMIN e Strip Kerberos.
    Escolha a versão do LDAP, meu caso é 3.

    Salve e depois de "Applay" aquela tecla verde na imagem anterior do Squidguard.

    Obs importante: Sempre que mexer nas regras ou configurações você tem que dar o "Applay".

    Pronto a integração esta feita.

    Segundo - Vi que a linha de busca no LDAP está errada. Ela esta assim:

    ldapusersearch ldap://192.168.20.1:3268/DC=domain,DC=com?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=adm,OU=Acesso,DC=dukar,DC=local))

    E na verdade deveria ser assim:

    ldapusersearch ldap://192.168.20.1:3268/DC=dukar,DC=local?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=adm,OU=Acesso,DC=dukar,DC=local))

    Vi que seu domínio é dukar.local... então o primeiro DC=domain deve ser mudado para DC=dukar e o segundo para DC=local.

    Faça testes...



  • @marcello-marques Essas configurações são para o modo autenticado do Squid.



  • Sim, tentei as duas alternativas. E não deu certo!

    Posso até te mandar os prints da minha tela, o usuário que eu criei dentro do AD para integração está com nome de Pfsense..

    Ressalto que meu Ad é Samba 4.. Será que tem algo a ver?



  • @rafamaximo2018 é a mesma versão minha. Pode ser que tenha algo errado com seu AD e não com o PFSENSE.
    Era pra funcionar direito essa questão de filtro do SquidGuard.
    Faça um checklist detalhado de todas s configurações... é demorado mas garanta que não esqueceu nada... Essa questão de integração do AD qqer detalhes pequeno, mesmo uma virgula fora de lugar, impede o bom funcionamento... Outra coisa, verifique esse esse usuário do AD não esta bloqueado.



  • Cara fiz e refiz 2 vezes essa verificação!

    Realmente não sei o porque isso acontece.... Será pq é samba 4?



  • Certamente é algo relacionado ao SquidGuard pois no Squid funciona as regras normalmente!

    Engraçado que eu dou o comando wbinfo -u e ele lista os usuários no pfsense inclusive o que eu criei para integração!



  • eu to achando que pode ser a complexibilidade de senha do samba4...

    Exemplo criei um usuário pfuser e senha = senha_1 sera que pode ser isso?



  • Peguei os logs do squidguard... segue:

    (squidGuard): ldap_simple_bind_s falhou: Requer autenticação forte (er)



  • @rafamaximo2018 Olha faz o seguinte, assiste esse video:

    Link de PFSense Integrado com AD+SquidGuard

    Tem ferramentas de testes..



  • Amigo consegui resolver!!! GRAÇAS A DEUS e ao forum aqui também!!!

    Velho vi isso no forum após os logs do squid....

    Para resolver o problema, tive que rebaixar esse nivel de segurança configurando o ldap server require strong auth como NO.

    Editei o SMB.CONF

    #vi /etc/samba/smb.conf

    E adicionei a seguinte linha no Global Parameters.

    ldap server require strong auth = no

    Salvei o arquivo

    #:wq!

    E reiniciei o serviço do Samba.

    Fiz e resolveu.. obrigaod demais viu!



  • Pessoal, boa tarde!

    Desculpe a demora... Consegui configurar os dois Squid e SquidGuard, mas o procedimento so fucnionou depois de reiniciar o FW, nao foi o suficiente reiniciar o serviço. Após isso! td funcionando, @Markinho1970 muito boa sua dica da versão parabens.



  • @marcello-marques Obrigado amigo...



  • Prezados..
    Apos fazer todos os processos tudo testado e funcionando o meu pfsense não habilita os campos Authentication Server e Port para digitar informações0_1547846747613_Screenshot_8.png



  • @marcelfreitas qual a versao do seu squid



  • @marcelfreitas qual a versao do seu pfsense, ja temos o script para versao 2.4.4


Log in to reply