TP Link EAP 330 Low Performance with pfSense

  • Hello everyone,

    I have recently installed pfSense in order to replace the Router/AP (Bbox) given by the ISP (Bouygues Telecom [FR]).
    The connection is a 500 Mbps/200 Mbps FTTH.
    The fiber gets connected to a modem and the output is 1 Gbps Ethernet cable that goes into the Router/AP.
    Having tried to connect to the ISP router via RJ45, the speed is around Down: 510/520 | Up: 200/205 Mbps.
    With the built in WiFi (5 Ghz) I can manage to have around Down: 420/450 Mbps Up: 200 Mbps.
    I have recently purchased a TP Link EAP 330 second hand and tried it on my pfSense box (Quad Gb Intel NIC).
    If I attach the PC directly to the pfSense LAN port the result are at max, i.e. Down: 510/520 | Up: 205/210, but when I connect the LAN port to the EAP 330 and then test with the PC the WiFi (5 Ghz) cannot pass the Down: 350/360 Mbps (Up is OK) barrier.

    The strangely lower range (at distance) of the EAP 330 vs the ISP box WiFi, made me think that it might be it, although, if I connect the EAP to the ISP box it will produce much better results than the internal Bbox WiFi and most of all around 100 Mbps better than when the same EAP 330 is connected directly to pfSense.

    Do you have anything in mind on why when connected to the ISP box it works correctly and when connected to pfSense it doesn't, despite the latter can manage higher speeds if the PC is directly connected to the port?

    Thank you very much!

  • Up!

  • Up!

  • Netgate Administrator

    Do you see any errors on the LAN interface in Status > Interfaces when the AP is connected?

    Try swapping out the cables if you have not already.

    Try adding a switch in between the pfSense LAN and the AP if you can.


  • @stephenw10 Hello!

    No errors or collisions on any interface.
    Tried a bunch of different cables with no results.
    Bought a switch a few weeks ago just to try that out and no improvement.

    Any other idea?


  • Netgate Administrator

    IT looks like the EAP330 has two Ethernet ports. Are they bridged? Can you connected a client to that directly and test from there?
    It looks like they also support lagg. You could try setting that up and see if that provides more. Though I see not reason why you should need that.


Log in to reply