Komisches verhalten bei Firewall-Rules



  • Hallo zusammen,

    erstmal vielen Dank für die zahlreichen Infos, welche ich aus diesem Forum genommen habe. Nun habe ich jedoch ein Problem, wo ich die Lösung leider nicht gefunden habe:

    Grob gesagt habe ich ein LAN WAN und OpenVPN Client. Manche Ports und manche IP-Adressen sollen über den OpenVPN Client getunnelt werden.

    Dazu habe ich 2 Firewall Rules erstellt (Datei: Rules). Die mit den Ports funktioniert super, die mit den IP-Adressen leider nicht immer.

    Die mit den IP-Adressen funktioniert meist nach einem Reboot (states reset reicht nicht). Wird eine Rule (egal welche) jedoch nur leicht bearbeitet (z.B. log an oder aus) und neugeladen funktioniert die mit den IP-Adressen nicht mehr.

    PS: Es gibt keine Floating Rule; wenn ich die LAN Rule in den Floating bereich verschiebe, funktioniert diese trotzdem nicht. Die Ip-Adressen gehen dann normal durch die Allow Any Rule...

    Ich hoffe mir kann jemand helfen.

    0_1545209876044_Rules.png



  • Hallo,

    möglicherweise hilft hier ein Haken bei "Skip rules when gateway is down" in System > Advanced > Miscellaneous.



  • Leider nicht, ich habe beide Haken aktiviert:

    "State Killing on Gateway Failure" und "Skip rules when gateway is down"

    Edit: Jetzt wird die IP-Rule auch nicht mehr nach einem Neustart gezogen...
    Seltsam...

    Edit: Ich glaube ich habs. Im DNS Resolver muss DHCP Registration und Static DHCP ausgewählt sein, wenn man Aliase verwenden will...


Log in to reply