Captcha et autentifications impossibles sur certains sites.



  • Bonjour,

    Après avoir oublié mon idée d'assurer le filtrage avec squid/pfsense (cf https://forum.netgate.com/topic/138281/exchange-reverse-proxy-ko-owa-tcp_denied-403)

    Aujourd'hui, j'étais venu au taf pour mettre en place le pfsense pendant que personne n'était là... Mais...

    Certains captcha ne fonctionnent pas et l'authentification sur certains sites non plus!!!!

    Contexte : milieu pro, administrateur pro système, mais profane pfsense, age de la solution firewall: nouveau pour test pour remplacement solution TMG hors d'age...

    Besoin : Changement de pare feu

    Schéma plateforme de test::
    Internet <-> pfsense <-> PC

    WAN (modem/routeur/box) : 1. type réseau. 1 IP publique sur pf sense (192.168.87.10)

    LAN : 1 (172.17.0.1) dhcp non concernés, dns local (utilisé par pf sense)

    Règles NAT : Là, c'est depuis l’intérieur vers l'extérieur... Je ne crois pas qu'il soit utile que je mette mes régles?

    Règles Firewall : règles principales:

    • Regle antiblocage (par défaut liée à l'interface d'administration)
    • défault allow lan to any rule en IPV4 et une autre en IPV6

    Packages ajoutés : aucun

    Autres fonctions assignées au pfSense : RAS pour le moment

    Question : Qu'est ce qui justifie qu'il est impossible de faire fonctionner par exemple les captcha de https://testconnectivity.microsoft.com (j'ai aussi une authentification sur un antispam qui ne passe pas) . J'en ai d'autres qui ne passent pas, par contre, j'en ai d'autres qui passent!!!



  • @cyrcocq said in Captcha et autentifications impossibles sur certains sites.:

    Règles NAT : Là, c'est depuis l’intérieur vers l'extérieur... Je ne crois pas qu'il soit utile que je mette mes régles?

    Ce qui m'intrigue c'est que, par défaut, il n'y a pas de règle à mettre. Sur pfsense dès lors qu'une interface est doté d'un routeur (upstream gateway de mémoire) alors tout le trafic passant par cette interface allant vers l'extérieur est translaté par défaut.

    Si vous n'avez que du filtrage niveau 3 et 4, je ne vois aucune raison liée à Pfsense pour les problèmes que vous rencontrez qui eux sont situées en couche 7.

    WAN (modem/routeur/box) : 1. type réseau. 1 IP publique sur pf sense (192.168.87.10)

    C'est une ip privée.



  • Salut,

    pfSense, une fois installé avec paramétrage par défaut n'est guère différant qu'un "box" de base. Si quelque chose cloche, faut chercher up-stream (t'as bien dit IP publique comme 192.168.87.10 : donc t'as un routeur en face de pfSense)
    Cad : rien est filtré. Toutes les connections LAN vers WAN (normalement : Internet) sont permis.
    "captcha " n'est qu'un tas de script (Java ou autre) présent dans un flux html, un routeur comme pfSense n'a pas influence sur le données (normalement) T'as changé de navigateur ou procédé à un reset de ton cache navigateur ?

    NAT ? Il suffit de rien toucher pour que tout marche. NAT, c'est utile dès qu'on utilise le vieux protocol comme IPv4 et on cherche à rendre accessible un appareil derrière pfSense (sur ton ton LAN par exemple).

    PS : Décoche "Block private networks and loopback addresses" sur l'interface WAN.