pfsense virtual machine on esxi not detecting more than NIC


  • I’ve installed pfsense as a virtual machine in esxi. Pfsense is not recognizing more than one network adapter. I can add another NIC in esxi (and am checking the connect box to make sure it’s connected), but pfsense doesn’t list it. The output of ifconfig only lists vmx0, and Interfaces > Interface Assignments only lists vmx0 as well.

    This seems relevant also: if I go back into esxi and remove the 2nd NIC, is says “failed to reconfigure virtual machine pfsense. Device ‘ethernet1’ does not exist”.

    I have installed the open vm tools package in pfsense, and rebooted for good measure.

    Using esxi 6.7.0.8169922, and pfsense 2.4.4-RELEASE-p1 (amd64)


  • @elyp Got it working. I had to blow away the whole virtual machine, and recreate it in esxi. Even though I had previously tried adding more nics in esxi, and then reinstalling pfsense all over again from scratch, it wasn’t getting more nics. So problem seems like it is on the esxi side with adding more nics to this type of vm after initial vm creation.


  • Similar issue here under ESXi 7.0 and pfSense 2.4.5-RELEASE-p1.
    Created a VM with one virtual NIC, booted installed OK.
    Powered off, added 2 other NICs, booted and they are OK.
    Added a 4th NIC while powered on, the VGA console shows that at operating system level it was detected hotplugged with correct MAC address, but in pfSense web interface did not appear.
    Rebooted, still not there.
    Powered off and back on, still not there.

    Deleted the whole VM, re-created from scratch with 4 NICs, re-installed pfSense from ISO, all NICs present.