pfSense on Hyper-V Server 2016: Strange Issues, Need Help!



  • Hello Everyone!

    So I have a multitude of things I've been doing with my pfSense router. WAN is running as interface hn0 and I also configured my Internal Network which is running as the LAN (hn1).

    Specs:
    Dell PowerEdge R710, 2x Intel Xeon E5520 CPU 2.26GHz, 32GB RAM @ 1067MHz, 1Gbit NIC with 4 Ports (Each acting as their own NIC in Hyper-V from what it seems)
    OS/Hypervisor: Windows Hyper-V Server 2016
    Latest Build of pfSense (2.4.4) inside VM
    Local Network: Class A (10.0.0.x)
    LAN Network (in pfSense) Class C (192.168.x.x)

    Past Issue: So I first ran into issues after I setup pfSense without the LAN. DHCP assigned the pfSense WAN with a local IPv4 and IPv6. The webConfig was working and I was able to setup the rest there. After I added the Internal Network and assigned it as LAN, the webConfig stopped working. Before and after that I do not think the pfSense router was facing the internet due to the packages page not being able to load any packages and info widget not being able to load neither.

    I began to troubleshoot thanks to some posts on here, but dug myself deeper into a hole. After doing clean installs and trying numerous things (i.e. Tried Private Network setting instead of Internal on the LAN (hn1) Network Adapter, restarting the gateway on my home network, Static MAC Address on WAN, MAC Spoofing.) After another attempt, I was not sure if the MAC addresses were part of the issue as when I tried to connect via web interface it pointed to a different IP - But Hyper-V creates a different MAC Address for each new vInterface created in a new VM so I threw that out. Between each time, I tried to ping websites and the local network through the virtual machine console and got hostname resolve failures. The local ping only worked when interface hn1 (LAN) was disconnected. I got rid of the extra pfSense devices off the network (pfSense1-6 lol) and tried again one last time.

    New Issue: Once I booted up pfSense one last time to figure some other things out, once the console hit "Configuring WAN Interface..." it froze there for a few moments and did not present any IP for WAN (hn0). Only for LAN (hn1). Now for each VM I create, WAN will not be configured or assigned by DHCP via my local Gateway. So the network is no longer touching the pfSense VM..? Very interesting. Not sure where to go from here.

    Any help is appreciated as I google more and search these forums!



  • Did you get your hyper-v pfsense running? If not, feel free to post again. I have a couple of pfsense instances running on a hyper-v server, so it's definitely possible to get it working properly.


Log in to reply