Cannot login to ntopng.



  • I also can find no errors in the logs and nothing special when I start the service from the shell.
    I have uninstalled ntopng and deleted /var/db/ntopng/ /var/db/redis/
    After that I installed it again, but I still can't login.

    I do notice that when I try to login I see the ntopng Desktop for a fraction of a second and than the login screen comes up again. I'm sure I use the correct credentials.

    Cor


  • Rebel Alliance Developer Netgate

    Do you maybe have some kind of ad/script blocking browser plugin in all the browsers you have tried? Or some kind of AV that might be interfering?



  • Just tried from another PC that does not have AV installed at all. It is pretty much a clean install of Windows 7. However I am noticing now that the Username and Password boxes are changing to Red after a few seconds. So I went back to the WebGUI to change the password and tried to log into ntopng again. Still changes to RED after a few seconds. Is it possible the at the password is not getting changed?



  • I just tried opening the page in Firefox and it works. I suppose I should have tried this earlier, sorry.
    I'll try to find out what is blocking the page in Vivaldi

    Thanks for your help pointing me in the right direction.

    Cor.



  • @MMTadmin , are you by chance running with /var file system in memory? Also, have you tried admin/admin as credentials after a reboot?



  • same here when running ntopng with ram disk.
    somebody running ntopng with pcengines apu board?



  • I have the same issue here. I can't login with Chrome, but with Firefox no problems.



  • I've had same issue.
    So I've done rm -r ... tip and reinstalled ntop, and now I can login.
    But when I'm trying to set password with pfsense GUI it doesn't change. It's always admin/admin.



  • I was able to set my ntopng password using redis-cli, following the method from an old locked thread.

    SSH into your pfSense and then run:

    echo -n NewPassword | md5
    

    (replace "NewPassword" with whatever you want for a password).
    That will show you the MD5 hash of your new password, which is what you have to actually use in the next step. Copy the output into your clipboard and paste into the redis-cli set command in the next step. For my example "NewPassword" the MD5 output is 70c04e53f3216a44d9b4f3e517f9b45c .

    Then:

    redis-cli
    set ntopng.user.admin.password 70c04e53f3216a44d9b4f3e517f9b45c
    

    After that, you should be able to log in with NewPassword or whatever you chose, using the "Access ntopng" page (Diagnostics->ntopng).

    I am not sure if this is persistent across reboots, as I haven't rebooted yet.



  • I have the same issue on my SG-3100 with ntopNG - and the workaround from damien_vancouver works for me.

    Any idea what the underlying issue is?

    It seems like the set password form in pfSense for ntopNG is broken somehow?



  • I have the exact same issue on 2.4.4-RELEASE and workaround from damien_vancouver is the only thing that works for me.



  • Hi ! Thanks for the workaround unfortunately the password is changed back after a reboot. Does anybody have a more permanent solution ?

    Thanks

    [Edit]Nevermind, I uninstalled the package, reinstalled it and set up the password using Edge. Now I can login (even in chrome)[/Edit]



  • Also had to use damien_vancouver workaround. Thanks damien_vancouver



  • This worked for me without having to use command line.
    First - do not change PW from pfsense. Turn on ntopng , save and got to web page
    Use default user/password: admin/admin. It should aks you to change from default password.
    Once submitted should go to dashboard page.

    If you already changed PW from FW, then uninstall (remember to unmark box to retain data and reinstall.



  • @damien_vancouver This solved the problem for me.
    Thanks!



  • The solution from @damien_vancouver also worked for me. I had the same problem described in this thread. In PFSense GUI, under ntopng settings....clear all files, data, graphs. Unchecked the box at the top of the page for "retain data, files".



  • And it still continues today.
    2.4.5-RELEASE-p1 (amd64)
    built on Tue Jun 02 17:51:17 EDT 2020
    FreeBSD 11.3-STABLE

    The system is on the latest version.
    Version information updated at Thu Aug 27 15:50:31 EDT 2020

    I will try the @damien_vancouver workaround and report back...



  • the @damien_vancouver workaround works again, thanks!



  • @bluedog said in Cannot login to ntopng.:

    This worked for me without having to use command line.
    First - do not change PW from pfsense. Turn on ntopng , save and got to web page
    Use default user/password: admin/admin. It should aks you to change from default password.
    Once submitted should go to dashboard page.
    If you already changed PW from FW, then uninstall (remember to unmark box to retain data and reinstall.

    One modification, when setting up ntopng on the setting page to get past that form set the password as "admin" which is the default for ntopng when you go to login to it for the 1st time.



  • @damien_vancouver's fix also worked for me.


Log in to reply