Inconsistent DL speeds



  • Hey everyone, I write today my first post on the forum. I've searched far and wide looking for a resolution, but have come up short.

    I have my openvpn server setup at home in New Brunswick Canada, I connect to it while working in Alberta Canada using my nvidia shield. Ping is 65-80ms.
    I followed the default setup for openvpn and connecting to the server was easy. However, I've never been happy with the DL speeds, speed test shows 30-50mbps, but in real world usage, network graphs on the openvpn for android app show regular dips to 0, 3.5Mbit/s - 0. When streaming video, the video buffers or down samples quality. Both the server (Bell) and the client (Telus) are connected on 1GBPS FTTH connections.

    After the initial setup I began tweaking the config, adding FAST IO and increasing the buffer size. But still, no Download speed increases or consistency. Still the regular dips.

    Oddly enough, the upload speed is where I would expect the hardware and connections to support. Real world usage of 75Mbit/s - 90Mbit/s.

    1. So i can't figure out why my download speed is 3-5Mbit/s and why it drops to 0 every 30 seconds or so.
    2. My cpu usage never breaks a sweat over 2%

    My setup

    2.4.4-RELEASE (amd64)

    Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz
    Current: 4400 MHz, Max: 4401 MHz
    4 CPUs: 1 package(s) x 4 core(s)
    AES-NI CPU Crypto: Yes (active)

    Last config change Fri Dec 28 17:47:58 AST 2018
    State table size 0% (158/803000) Show states
    MBUF Usage 1% (4056/498298)
    Temperature 27.9°C
    Load average 0.07, 0.05, 0.01
    CPU usage 1%
    Memory usage 4% of 8034 MiB
    SWAP usage 0% of 3881 MiB
    Disk usage: / 1% of 104GiB - ufs
    /var/run
    3% of 3.4MiB - ufs in RAM

    Config

    dev tun
    persist-tun
    persist-key
    cipher AES-128-CBC
    ncp-disable
    auth SHA256
    fast-io
    sndbuf 524288
    rcvbuf 524288
    push "sndbuf 524288"
    push "rcvbuf 524288"
    tls-client
    client
    resolv-retry infinite
    remote 140montgomery.sytes.net 1194 udp
    auth-user-pass
    remote-cert-tls server

    Any help would be greatly appreciated.



  • I should add, I have tried increasing and decreasing buffer size, I've tried switching UDP ports and removed cipher encryption all together. Nothing changes to download speed from my Nvidia Shield ethernet connected.