vlan works allocates dhcp and web access only when connected to LAN port and stop when connected to switch or AP



  • hi all,
    I have a VLAN that routes traffic to wan 2
    I configured VLAN on my new pfsense,
    I connected the LAN port to my mac and a VLAN my interface and VLAN and my regular LAN both work great and both get DHCP addresses

    my problem starts when I connect my LAN to my managed switch,
    (for now, only I am connected via LAN to the switch and switch to the pfsense,
    my regular network gets a DHCP but my VLAN won't get DHCP, and if I set the address manually it won't connect to the web.
    same setup but this time via the switch.
    I also tried to connect to the switch my Aruba ap 207 and there I set up a guest network that should go to my VLAN (id 30) and again no DHCP and no connection to the web when entered manually.

    what am I missing?

    thanks
    ofir



  • @shtrull said in vlan works allocates dhcp and web access only when connected to LAN port and stop when connected to switch or AP:

    what am I missing?

    What's the managed switch configured for? It has to pass the same VLAN as used on the Mac. You mention the AP is configured for VLAN 30, but didn't mention what the computer was configured for. You need the computer, switch and AP all configured for the same VLAN. You'll also have to ensure the DHCP server is configured for the VLAN interface.

    BTW, does your computer have a Mac address? 😉



  • first, I configured the AP to VLAN 30 of course.
    I tried to configure the switch but it gave me only a per-port VLAN and I need my AP to be for both vlan and plan together
    shouldn't the switch transfer the VLAN to any client that is configured to accept the VLAN with the right configuration? not matter of the switch?

    and the VLAN has DHCP configured and when Connecting to the port of the pfsense it works straight away



  • You need to configure a trunk port on the switch, for both the firewall and AP. Other ports can be configured as access ports on specific VLANs. You again said VLAN 30 on the AP, but no mention of the switch or pfSense. Are they also configured for 30?



  • @jknott thanks for your help,
    finely i got it to work, i needed to add the VLAN to the switch and then tag the ports i want to transfer the VLAN with