Windows 10 updates blocked by proxy (squid)?



  • Squid is working with browsers but not by windows updates for windows 10. I wonder if i have to import .cert to the local copmputer to make it work properly? I know when i am turning squid off updates works as i was downloading the montly updates this evening.



  • @lindsay said in Windows 10 updates blocked by proxy (squid)?:

    I wonder if i have to import .cert to the local copmputer to make it work properly?

    Yes, if you're running squid in transparent mode. You're better off disabling transparent mode, then configuring WPAD and let your Windows clients find the proxy on their own. Then https will work without certs.



  • On all Windows 10 computers open cmd (as admin) and type:

    1. netsh winhttp set proxy 192.168.0.1:3128 "<local>" -> Enter - address and port is your proxy machine address
      or if you have an active directory domain type:
    2. netsh winhttp set proxy 192.168.0.1:3128 "<local>;*.your.domain" -> Enter
      Windows Update works good with that settings. You can do the same with .bat, as domain admin.


  • Manually specifying the proxy kind of defeats the whole purpose of transparent mode, no?



  • I have no transparent proxy, and on each computer set manually: All settings -> proxy settings I set proxy address and port. With that Windows 10 trying WU connect by 80/443 ports (blocked in squid). When I set: netsh winhttp set proxy then WU works great.



  • I use WPAD and squid in explicit mode. All my Win10 clients have no problems updating through squid so I'm not exactly sure what his problem is nor do I know his configuration. This thread is 2 months old and OP never responded, so I suspect we're both wasting our time here.



  • I think problem isn't with squid, rather with Windows 10 - system proxy settings doesn't enought, I don't know why. But with winhtt set proxy it works. Respect for your work, KOM and best regards.


Log in to reply