WPAD Autconfig + WebConfigurator distinto puerto de acceso



  • Que tal amigos, un saludo a todos.

    Explico mi consulta a los gurús existentes en este foro. Llevo usando pfSense desde hace varios años con la famosa combinación Squid+SquidGuard en modo TRANSPARENTE, hasta aqui todo perfecto. En las diferentes instancias que tengo el pfSense funcionando los equipos superan el numero de 300 a 400 PCs, el modo transparente es lo ideal para no tener que tocar todos los equipos y configurarles una direccion proxy manualmente.

    Hace unas semanas quise implementar el modo NO-TRANSPARENTE de Squid utilizando para evitar la configuración de cada equipo la opción WPAD con DNS Resolver y DHCP 252 String, pero Oh! sorpresa, por seguridad yo siempre configuro el puerto de acceso al pfSense al GUI por un puerto distinto al 80, y me percato que la auto-configuracion del WPAD por DNS Resolver y DHCP falla cuando se cambia ese puerto de acceso webConfigurator.

    Si configuro el TCP Ports del webConfigurator al puerto por default (80) todo me funciona correctamente y el squid solicita autenticacion. Firefox, Chrome, Safari y dispositivos móviles pueden navegar pasando por el proxy sin problemas, pero si cambio dicho puerto no pueden.

    Alguno ha tenido este mismo problema?

    Agradezco sus comentarios.



  • WPAD hasta donde se solo funciona en el puerto 80, saludos.



  • Verifica este tópico podría serte útil.



  • Me respondo yo mismo y doy por cerrado el caso.

    Al cambiar el puerto de acceso 80 a otro en caso de HTTP, en caso de HTTPS 443 a otro cualquiera, el servidor WEB que sirva el archivo de configuracion "Wpad.dat, Wpad.da y Proxy.pac" no puede ser el propio pfSense. Esto debido a que los navegadores buscan esa autoconfiguración siempre por el puerto 80 y es por eso que la autoconfiguración falla en los navegadores y dispositivos.

    El caso queda resuelto simplemente instalando un contenedor con el servidor WEB NGinx en mi caso pues yo uso Proxmox en mi servidor, y listo! CASO CERRADO...



  • @sysmus Perdón por "retomar"algo que ya ha sido cerrado hace tiempo, pero quisiera saber si en los dispositivos móviles funciona bien wl WPAD, porque lo que estuve leyendo y viendo en Youtube hasta ahora es algo viejo y en ese momento se decía que los dispositivos móviles tenían problemas con WPAD y había que configurarlos manualmente. Es cierto o ya han podido solucionar esto?
    Desde ya, muchas gracias.



  • Referido a Android oficialmente no es soportado actualmente y las perspectivas no parecen alentadoras.
    Ver más detalles en este link.


Log in to reply