Tinydns dnscache configuration not showing in menu in pfSense 1.2.3?



  • (I originally posted this in the "DNS server testing area", but this is probably a more appropriate place for it.  I'll remove the other posting.)

    Yesterday evening I installed a recent snapshot build of pfSense 1.2.3 from 3/7. (See my note in the Installation section of the forums.)

    I'd like to enable dnscache as a local caching forwarder.  That is the way I had set it up on my old firewall, and IMHO it provides a slight but noticeable performance boost, together with some protection in theory against DNS-based attacks.

    This morning I added the "dns server" package from the packages menu (and squid, in case it's relevant.)  A "DNS Servers" entry was added to the services menu, but it always takes me to the "New zone" wizard to set up a zone in tinydns, which I don't want to do at all.

    Was I mistaken in installing the dns server option to get dnscache?  If so, can I safely remove the package?

    If it does include dnscache, can I configure and enable dnscache from the web interface, or do I need to go do that from the shell command line?

    Thanks for any help you can offer.


Log in to reply