[solved] Unbound restarts every time an OpenVPN user connects



  • Is it normal that Unbound is restarting every time an OpenVPN user connects to the system? I thought it might be because of the option "Register connected OpenVPN clients in the DNS Resolver" in Unbound, but I disabled that option and still Unbound restarts every time?

    The restart makes the system unusable for some time as because of pfblocker-ng Unbound needs some time to restart.


  • LAYER 8 Global Moderator

    Do you have it listen on all interfaces and use all interfaces for outbound?



  • Yes, both "Network Interfaces" and "Outgoing Network Interfaces" are configured to the default "All".


  • LAYER 8 Global Moderator

    Set them only to the interfaces you need, and see if that fixes your problem... Its possible that unbound is restarting on seeing a interface go up/down??



  • @johnpoz I just tried to set the listen interfaces to only my local ones and the outgoing interface to "WAN". However that did not help. The OpenVPN interface is not in the list so I cannot exclude that.


  • LAYER 8 Global Moderator

    Let me connect in real quick from phone to vpn..

    Yeah just connected, no restart of unbound..

    You sure your uncheck of register vpn users took? Look in your conf



  • @johnpoz That is what I would expect. For me it seems that it still tries to register the hostname of the VPN client. However, I can confirm, if I disable that option a "dig <hostname>" does not resolve the name but enabling that option does. However, in both cases, Unbound is restarting as soon as the VPN connection has been established.



  • @johnpoz Can I verify somewhere directly in a config file, if the option has been disabled? For what should I look for? In the GUI it is disabled.



  • @johnpoz I needed to reboot the pfSense box today for another reason, and it seems that Unbound now no longer restarts if an OpenVPN connections is established. So I guess that was only a temporary issue. Thanks for your help!