PFsense virtualized by proxmox: GW2 blocked



  • pfsense 2.4.4 amdx64
    on proxmox with linuxbridges virtual Intel1000 netcards (2 cores 4vcores, 15Gb memory for diskram at last). all interface are linux bridge to non real connexion (exept the two gw real interface to internet)

    test platform:

    • two virtualized GW (GW1,GW2) on debian doing masquerading and acting as gw to offer two different virtual LAN, from the same internet source.
    • one virtualized pfsense with 6 netcards. ( GWFIBRE (connected to GW1),LAN,GWADSL ( connected to GW2),OPT1,OPT2,OPT3).

    test on GWs:
    connecting a test virtualized UC show direct connecting to internet via gws work.

    configuration PFSENSE:
    i want to do load balancing and failover with the two GWs with different methods on the differents LANs. ( with groups of GW).
    Each GW is configured and have a test ip ( 8.8.8.8 and 8.8.4.4).
    with success i have the GWFIBER working well, but never i have The second one GWADSL one(detected as down).
    ping to 8.8.4.4 or anything on net from GWADSL do not work at all. but pinging GW2 interface correctly and interfaces are ups.
    Systemlog say.
    After some reboots, no GW work at all..

    other tries:
    doing the same thing on 2.3.4.

    don't understand anymore what happen, on real material i have already do it without any problems.

    reapplying experimental test from 0:
    it appear than gw look down, but gws work perfectly....is there some problems in gw up detection ?

    -> to resolv you need to restart routing soft with cycle button.


Log in to reply