Problem mit Routing aus dem OPT1-Netz



  • Ich habe folgende Situation:
    Hauptnetz 10.43.80.x
    Subnetz: 192.168.112.x
    Im Hauptnetz steht ein Router mit der IP 10.43.80.1 zu einem Rechenzentrum mit Netz 172.x.x.x.
    Die PFsense mit außerdem 2 WAN (VDSL) Anschlüssen hängt quasi parallel mit der IP 10.43.80.11 im Netzwerk. Wir können problemlos vom internen Netzwerk in das Rechenzentrum (Route in PFsense eingetragen) zugreifen.
    Das Problem: Der Zugriff über das OPT1-Netz funktioniert nicht. Ein Trace endet an der PFsense (OPT1 mit der IP 192.168.112.1).

    Hat jemand eine Idee, wo ich ansetzen könnte? Wo das Problem liegt?



  • Deine Formulierung ist ziemlich unklar.

    @theller said in Problem mit Routing aus dem OPT1-Netz:

    Hauptnetz 10.43.80.x
    Subnetz: 192.168.112.x

    Gibt es für die beiden Netze keine passenderen Bezeichnungen?

    @theller said in Problem mit Routing aus dem OPT1-Netz:

    Im Hauptnetz steht ein Router mit der IP 10.43.80.1 zu einem Rechenzentrum mit Netz 172.x.x.x.
    Die PFsense mit außerdem 2 WAN (VDSL) Anschlüssen hängt quasi parallel mit der IP 10.43.80.11 im Netzwerk. Wir können problemlos vom internen Netzwerk in das Rechenzentrum (Route in PFsense eingetragen) zugreifen.

    Ins Rechenzentrum geht es doch über den Router? Das lässt jedenfalls der erste Satz vermuten.

    Was ist das "interne Netzwerk"? Eines der beiden oben genannten? Wie ist es mit der pfSense verbunden?

    Vielleicht lässt sich dein Anliegen in einer Grafik verständlicher ausdrücken.



  • ok. Danke für die Hinweise. Ich versuche es mal mit der Grafik:
    0_1547487986435_skizze.jpg

    Der Zugriff soll aus dem Subnetz 192.168.112.x auf das Rechenzentrums-Netz 172.x.x.x erfolgen. Trotz Route, findet er das Netz nicht. Eine Firewall-Regel wurde ebenfalls angelegt.

    Ich hoffe, das hilft jetzt zum Verständnis weiter.
    Danke schon mal.



  • Es bedarf einer statischen Route auf der pfSense und einer am RZ-Router.

    Auf der pfSense für das Netz 172.x.x.x mit Gateway 10.43.80.1
    Und am RZ-Router für das Netz 192.168.112.x mit GW 10.43.80.11

    Sind die beide eingerichtet?

    Edit:
    Wenn die pfSense LAN IP am Router das Default Gateway ist, ist natürlich keine zusätzliche Route erforderlich.


  • LAYER 8 Rebel Alliance

    Netz 172.x.x.x? Was soll das sein?
    Du wirst im RZ ja wahrscheinlich/hoffentlich kein 172.0.0.0/8 Netz haben.
    Was spricht dagegen den "Router RZ" zu eliminieren und alles über die pfSense zu machen?

    -Rico



  • Nein, im Rechenzentrum spreche ich verschiedene Server direkt über eine Domain an. Ich habe natürlich keinen Zugriff auf "alles".

    Den Gedanken, den Router RZ zu eleminieren hatte ich auch schon, das hat historische Gründe. Ein VPN-Server (10.43.80.20) verbindet dauerhaft unsere Außenstellen und diese müssen auch auf Server des Rechenzentrums zugreifen. Ich müsste einige Router anpassen und das wollte ich vermeiden. Deshalb hätte ich die Hoffnung, das ich es über die PFsense anderweitig hinkriege.



  • @viragomann Ja es ist ein Gateway eingerichtet auf der PFSense:
    Interface Gateway Monitor IP
    LAN 10.43.80.1 10.43.80.1

    Die Route im RZ-Router wahrscheinlich nicht. Ob das Default-Gateway im Router passt werde ich mal prüfen lassen (Kommt nur das RZ dran). Es könnte die Ursache sein. Derzeit wird die Route anderweitig ja nicht gebraucht. Ich melde mich, sobald ich Rückmeldung habe.
    Danke erstmal



  • @theller und logischerweise auch statische Routen auf dieses Gateway für
    172.20.0.0/16
    172.21.0.0/16
    172.22.0.0/16

    @theller said in Problem mit Routing aus dem OPT1-Netz:

    @viragomann Ja es ist ein Gateway eingerichtet auf der PFSense:
    Interface Gateway Monitor IP
    LAN 10.43.80.1 10.43.80.1

    Die Route im RZ-Router wahrscheinlich nicht. Ob das Default-Gateway im Router passt werde ich mal prüfen lassen (Kommt nur das RZ dran). Es könnte die Ursache sein. Derzeit wird die Route anderweitig ja nicht gebraucht. Ich melde mich, sobald ich Rückmeldung habe.
    Danke erstmal


  • LAYER 8 Moderator

    @theller dein Hinweg ins RZ ist sehr wahrscheinlich OK, aber dein Rückweg nicht. Dein RZ weiß somit nichts vom "Subnetz" 192.168.112.x -> da muss in die VPN Verbindung zwischen Router RZ und dem Gegenstück im Rechenzentrum noch zusätzlich die 192.168.112.0/24 als zweites lokales Netz rein, sonst finden die Pakete nie wieder den Rückweg aus dem RZ zu dir.