Forward IP in TUN mode



  • Hi everyone,

    OpenVPN is running currently for road worriors in TUN mode with PFSense flawless.
    Within the corporate network traffic should be routed differently if someone is connected via VPN.

    At the moment all traffic within the corporate network from the VPN seems to come from the IP address of the OpenVPN server and not from the virtual IP address of the connected clients.
    Therefore it is not possible to distinguish between local traffic and traffic comming from the VPN clients.

    How to set up IP forwarding in TUN mode with pfsense ?

    Cheers!



  • @flunkyball
    Hi
    OUTBOUND NAT on the local interface enabled for OPENVPN clients ?
    If yes , disable it . Then the IP address will not change

    Specially connected through Openvpn to the network (got the address 192.168.20.2, server address 192.168.20.1)
    Verified
    Virtual ip does not change

    0_1547810995959_bc0502c5-245f-4ef4-bdb3-7fd7dbad7d59-image.png



  • @Konstanti
    Thx for the help.
    Indeed outbound NAT was enabled. After changing that everything works as exspected.


Log in to reply