OpenVPN Arp issue on reconnect with TAP



  • I am on pfsense 2.4.4-p2

    My Openvpn client is TunnelBlick running on OSX.

    When I put my laptop to sleep (close lid) then come back to it 2-20 minutes later, the VPN reconnects but won't pass traffic through the gateway (.254) if I log in to another machine on the subnet (.1) then ssh from .1 over to .254 and delete the arp entry for my macbook's VPN (.50), connectivity is restored.

    In the openvpn server config I have dynamic IP unchecked, and duplicate connection unchecked.

    I have to use tap because of Steam In home streaming.

    Ideally, when I reconnect to the VPN with a different random MAC address (this seems to happen by default?), PFSense would age out the old arp entry for the same IP, or give me a different IP.

    Thanks


Log in to reply