pfSense "hängt" sich gelegentlich auf



  • Hallo,

    ich habe eine APU 4B4 mit 32GB mSata SSD im Einsatz und habe dort sporadisch ohne erkenntlichen Grund Aussetzer.

    Diese zeigen sich im Telefon (VoIP Telekom) wie auch im Handy (WhatsApp und surfen) habe aber das Gefühl zuweilen, das nicht der ganze Verkehr brach liegt; kann das aber nicht belegen. Meist ist es so wenn wir im Telefon sehen das keine Verbindung hergestellt werden konnte, stöpseln wir die pfSense einmal aus und wieder ein und wenn sie hochgefahren ist, geht wieder alles seinen gewohnten Gang.

    Es ist die 2.4.4-RELEASE-p2 (amd64) installiert, da davor war die unstable installiert; ich dachte zuerst daran lag es. Nun taucht aber der gleiche Fehler auch mit der jetzigen Installation auf.

    Meine Fragen wäre:

    1. Wie kann ich in dem Moment, indem ich merke, das nichts "mehr geht", herausfinden, wo die Ursache liegt? Ich meine der Zugriff auf die GUI ist möglich.

    2. Oder ist das Problem so nachzuvollziehen woran es lag?

    3. Oder ist es ein "altes" Problem und ihr könnt mir so helfen?

    Vielen dank, Patrick



  • Schonmal versucht, ein paar Minuten zu warten? Geht die Verbindung automatisch wieder? Oder erst nach einem Neustart?
    Funktioniert die pfSense GUI sicher, wenn nichts mehr geht?

    Schau mal im DNS Resolver Log, ob der Resolver zu der Zeit neu startet. Hast du "Register DHCP leases in the DNS Resolver" aktiviert? Dann das entfernen.

    Viele Grüße


  • Rebel Alliance Moderator

    @morpher said in pfSense "hängt" sich gelegentlich auf:

    Oder ist es ein "altes" Problem und ihr könnt mir so helfen?

    Nein, "einfach so geht nicht mehr" gibts im Normalfall nicht.

    @morpher said in pfSense "hängt" sich gelegentlich auf:

    Oder ist das Problem so nachzuvollziehen woran es lag?

    Hängt davon ab was genau nicht mehr geht. Klar kann man immer den Router ausstöpseln wenn das Telefon nicht geht, kann aber auch sein, dass das nur ein Symptom nicht aber die Ursache ist.

    @morpher said in pfSense "hängt" sich gelegentlich auf:

    Wie kann ich in dem Moment, indem ich merke, das nichts "mehr geht", herausfinden, wo die Ursache liegt? Ich meine der Zugriff auf die GUI ist möglich.

    Wenn die GUI geht, einloggen und mal in den Logs schauen? Nen Ping von der UI absetzen? Solche Sachen?



  • @bepo said in pfSense "hängt" sich gelegentlich auf:

    Schonmal versucht, ein paar Minuten zu warten? Geht die Verbindung automatisch wieder? Oder erst nach einem Neustart?

    Ja, das passiert ja immer "irgendwann" und ich merke es dann "irgendwann". Es geht dann solange nicht, bis ich einen Neustart mache.

    @bepo said in pfSense "hängt" sich gelegentlich auf:

    Funktioniert die pfSense GUI sicher, wenn nichts mehr geht?

    Das muss ich beim nächsten Hänger testen, aber grundsätzlich weiß ich, das das interne Netz funktioniert.

    @bepo said in pfSense "hängt" sich gelegentlich auf:

    Schau mal im DNS Resolver Log, ob der Resolver zu der Zeit neu startet. Hast du "Register DHCP leases in the DNS Resolver" aktiviert? Dann das entfernen.

    Du meinst unter Services - DNS Resolver - General Settings ? Der ist aus. Musste das eben auf Englisch umstellen damit ich sowas ähnliches finde :-)

    @jegr said in pfSense "hängt" sich gelegentlich auf:

    Hängt davon ab was genau nicht mehr geht. Klar kann man immer den Router ausstöpseln wenn das Telefon nicht geht, kann aber auch sein, dass das nur ein Symptom nicht aber die Ursache ist.

    Die Ursache würde ich gerne finden, nur WIE? Dafür müsste ich ja den Zeitpunkt genau abpassen, um dann im Log zu schauen wo es genau dran liegt? ich erkenne das Problem aber erst immer später...

    @jegr said in pfSense "hängt" sich gelegentlich auf:

    Wenn die GUI geht, einloggen und mal in den Logs schauen? Nen Ping von der UI absetzen? Solche Sachen?

    In welchen Logs genau und nachwas? Die sind ja etwas umfangreicher und ich weiß jetzt nicht nach was ich da suchen soll, da ich ja den Moment nicht genau abpassen kann. Den Ping probier ich dann auch wenn es soweit ist, das interne Netz geht aber, da bin ich mir zu 99% sicher.

    Trotzdem danke mal soweit für eure Hilfen.



  • Da kann man sich erstmal nur dem Rat von @JeGr anschließen. Würde wenn es hängt mal auf die WebGUI und die Logs durchschauen. Kannst du natürlich auch so schon, ist aber schwieriger einen Zeitpunkt zu finden.

    Und dann halt normales Troubleshooting.

    An einem PC in deinem Netzwerk
    Ping PC > Gateway
    Ping PC > 8.8.8.8
    Ping PC > www.einedomaindiedunormalnichtansurfst.de

    Von der pfSense GUI
    Ping Gateway > PC
    Ping Gateway > 8.8.8.8
    Ping Gateway > www.einedomaindiedunormalnichtansurfst.de

    Ggfs. auch ein tracert von deinem PC zu 8.8.8.8 erstellen.



  • Vielen Dank erstmal. Ich werde dann mal abwarten das er die Symptome wieder hat und dann die tips durcharbeiten und mich dann wieder melden..


  • Rebel Alliance Moderator

    Zusätzlich kann man in den System Logs auch mal einfach nach seltsamen Logeinträgen durchsuchen der letzten Stunde oder so, bis einem das aufgefallen ist. Auch mal Dinge wie bspw. die Gateway Logs anschauen, ob es vielleicht ein Problem gab, dass das Gateway weg war/ist, DHCP/DNS Logs schauen, ob es da Fehler bei der Namensauflösung gibt usw usw :)