IOS 12.1.2 and 12.1.3 not working with Captive portal



  • Hi all,

    I'm experiencing an issue with the last IOS versions (12.1.2 and 12.1.3). After the wireless connection is established the landing page is not been splashed. Versions 12.0.1 and before are working fine. I'm using pfSense version 2.3.4. I know that probably this is caused for a misconfiguration but I'm very confused due with version 12.0.1 and older works fine.
    If someone can help I'm able to share all the necessary information.

    Thanks in advance!!!


  • LAYER 8 Rebel Alliance

    A lot of Captive Portal changes happened in pfSense 2.4.4
    I'd just try and update pfSense, maybe it will fix your problem this way.

    -Rico



  • Thanks for you soon answer. I'll be testing 2.4.4 today.



  • Back then, when I was using pfSense 2.3.4, the captive portal worked very well.
    iPhone, Android, what ever. With the OS's that existed at that moment.

    But "iOS 12.1.3" didn't exist these days, so only you can answer your question.

    Btw : 2.4.4 P2 rocks. Also when I use my old iPhone 4S with iOS 9.x or something like that.



  • Sorry for the delay. After the upgrade and some other configurations like HTTPS the IOS issue was solved. Thanks a lot!!


Log in to reply