Captive portal isn't getting displayed to VPN clients on a server from behind pfSense

  • Hello there,

    I have this messy configuration which is causing me lots of trouble to get things done, but it's all part of my hobby to tinker with these stuff to learn more about them.

    I have a private network on the cloud, pfSense instance acting as a firewall, behind it there are other instances of different servers and particularly a VPN server that is running behind pfSense.

    I am able to connect to that VPN server using pfSense's IP (Ports forwarded ofc to the DHCP IP of the VPN server) and after a successful connection the client gets its IP on the DHCP server of pfSense correctly as intended. The issue is, when the client tries to access the internet "while tunneled ofc" the captive portal prevents it (as expected) but it doesn't get loaded! The browser just gets redirected to the url of the captive portal but it hangs there and never loads.

    I have the Captive Portal set on LAN and it works perfectly when accessing the internet from any device on the private network itself, but for VPN clients on one of those servers behind pfSense, it doesn't.
    I tried both tun (L3) and tap (L2) for openvpn, along with L2TP connections too, all same result.

    What could the issue be and how to solve?

Log in to reply