Freeradius 3.0 on Pfsense 2.3.4 problems



  • Hi all,
    I have Pfsense router that I had configured to run Freeradius and PPPoE Server. If I configure the PPPoE server to use Freeradius to authenicate PPPoE users/clients, it works. Now i wanted to set bandwidth limits to the authenticate user, but that doesn't seem to work correctly. It seems that no matter what numbers I put in the Traffic and Bandwidth/Maximum bandwidth down/up, the user gets 5M/5M down/up. Any ideas why this is happening?
    Could this be related to vendors equipment? That is, does this attribute only work for certain type of equipment?


  • Netgate Administrator

    Do you really mean pfSense 2.3.4? That is quite an old version. Older than the Freerdius 3 package by some way IIRC.

    What bandwidth do you see if you don't add any values there?

    Steve



  • Sorry for the delayed response.
    Yeah its running 2.3.4. It says its running the latest version. I'd like to upgrade though. Its a board running from a compact flash card. Do I need manually upgrade by taking out the CF and write the latest version to it, or write the lastest version to another CF?

    If I don't add any values to the fields, it works basically the same. you get about 5M/5M.

    Before I upgrade can I do a configuration backup, to be restored after the upgrade? Pls advise. TIA.


  • LAYER 8 Global Moderator

    nanobsd went away with 2.4.. You could use the memstick installer.. But you prob need to boot from usb or something and then install to the CF. Its no longer an actual image that you write to the CF.

    You prob be better off moving to say a ssd or something in the box? What specific box are you running?

    2.3.x is no longer support and is DEAD... You can for sure backup your config and then restore it when you running current 2.4.4p2.. You know they gave notice about 2.3 going to be dead for well over a year, and that it was time to move to 2.4

    But not sue I would run off a CF to be honest..


  • Banned

    @johnpoz said in Freeradius 3.0 on Pfsense 2.3.4 problems:

    2.3.x is no longer support and is DEAD...

    And if your Box is 32-bit only it's DEAD as well.


  • Netgate Administrator

    Mmm, from another post : "I forgot to mention that the box is running Pfsense ver 2.3.4 I386."

    It's possible that's running 32bit on 64bit hardware but....

    If it's 32bit hardware you can only upgrade to 2.3.5, which you should be being offered even for Nano.
    But that's time to upgrade!

    Steve



  • OK I understand the need to upgrade. IIRC the board has some SATA ports. I can probably put in a hard disk, but its still 32 bits.
    But back to the original problem. Do you think it's related to my hardware?


  • LAYER 8 Global Moderator

    Doesn't matter if your hardware was never used out of the box. If your 32 bit, its time for new hardware.. Running a firewall that is years out of date is pointless!!

    Almost 2 years ago was when you should of been planning your upgrade strategy... Which is when they announced the end of 32 bit support..

    Here is what I would do - order some new hardware today! You could prob get a sg1100 or 3100 in a few days ;) Or something bigger maybe..


  • Netgate Administrator

    What is the hardware you have? It is possible it's 64bit and you just have a 32bit install.

    Steve



  • Here is processor on the board I am using:

    CPU Type Intel(R) Celeron(R) CPU 1037U @ 1.80GHz
    2 CPUs: 1 package(s) x 2 core(s)

    From my research it is 64 bits, so I may be lucky. I'll upgrade soon. What's the minimum size SSD I should get?

    Could my original problem be hardware related?


  • LAYER 8 Global Moderator

    Well what size CF did you have? Clearly you were not running packages that used up space like Proxy or ntop or IPS or pfblocker?

    You could get pretty much smallest there is like 16GB would be huge amount of space unless you plan on running some HUGE cache for proxy, etc. Or lots of logging with ntop, etc. etc.


  • Netgate Administrator

    You can probably just do a full 64bit install to the CF card and it will be fine for years as long as you remove the SWAP partition and move /var and /tmp to RAM after the install.

    Given that you almost certainly can run 64bit it's pointless trying to diagnose the initial issue until you're running 2.4.4p2.

    Steve



  • Thanks for the responses. I will be doing the re-install later today/tonight and get back to you tomorrow. I'll try to find the appropriate install instructions to implement the upgrade/re-install.



  • Ok guys I have upgraded to the lastest of Pfsense, so my router is now running 2.4.4-RELEASE-p2 (amd64).

    I had done a backup from the old version and restored it to the new version. Since the upgrade I have an additional problem. The PPPoE client that used to connect normally is now connecting and disconnecting every 1 minutes. I had to change the IP address under Freeradius/NAS/Clients to "*" for it to give the behavior it is now doing. If I put the IP address of the PPPoE server in there it does not work, and get a message in System Log, something about "Unknown Client". In the previous version I had the IP address of the PPPoE server. Maybe now I need to put in additional config for it to stay connected?


  • Netgate Administrator

    I think we'll need to see some screenshots of you config to diagnose that.

    Steve



  • Screen shots of what part of the config?

    I have figured out that this problem has to do with Freeradius I noted that if I disable the use of freeradius for authentication my connection to the PPPoE server stays up.


  • Netgate Administrator

    Ok well check the logs. It might show why it's disconnecting after a minute.

    Otherwise we'll need as much detail as possible here. The PPPoE config and freeradius config at least I would think.

    Steve



  • Here are the screenshots of the Freeradius config and PPPoE server. I had disabled Radius authentication to let PPPoE work.

    2_1550849753444_Screenshot (11).png 1_1550849753444_Screenshot (10).png 0_1550849753414_Screenshot (9).png



  • To see any possible FreeRadius issue :
    Stop FreeRadius in the GUI.
    Enter console - option 8.
    Start FreeRadius by hand using debug mode.

    radiusd -X
    

    (that is a capital X)

    Note :
    To eliminate possible future troubles :
    0_1550850671446_609ab78f-84c2-40ec-a8fa-c1fcf9ab9b49-image.png
    Don't use the 8000 port range.



  • here is a sample of what I received when I ran radiusd -X from console:

    0_1550862869552_Screenshot (12).png

    I had re-enabled PPPoE server to use radius authentication.



  • That same error keeps looping every minute or so.


Log in to reply