SOLVED: HEOS Multicast Control on different VLANs



  • I am moving from a UniFi Security Gateway (USG) to pfSense for my routing and firewall. I have multiple VLANs setup with a managed UniFi switch and UniFi access points. I have IGMP enabled on my switch. With the USG, I can control my Denon receivers with the HEOS app with multicast enabled and by allowing communication between my IoT VLAN and my VLAN used by my cell phone. Both devices connect via WiFi through different SSIDs and different subnets. As I mentioned, everything works with the UniFi USG. When I switch to pfSense, it does not work unless I am on the same VLAN. I have multicast enabled with Avahi. Avahi appears to be working as I can see the receivers on the bonjour network and I can see the receivers as speakers with Spotify which uses multicast. I cannot get the HEOS software working, even if I open up full communication in the firewall between VLANs.

    Is there some other setting in pfSense that functions differently than the UniFi USG that I need to enable?

    For reference, here is an article from Denon explaining what communication is necessary for the HEOS controller software
    to access the receivers:
    Denon Network Requirements


  • Netgate Administrator

    You probably need the IGMP proxy running between those subnets.

    Steve



  • I had to use PIMD. IGMP Proxy wasn't routing the information properly. It sure would be nice if PIMD was default in the GUI if IGMP Proxy isn't able to route multicast for items like HEOS and Sonos.

    I followed this tutorial.



  • @dennypage
    Denny posted in a Sonos thread that HEOS could work without resorting to PIM or IGMP proxies, i.e

    Check these things:
    You have firewall interfaces in both the client subnet (where your iPhone is) and the server subnet (where the HEOS device is).
    You have Avahi (2.0.0_2) with the allowed interfaces set to include both the client subnet and the server subnet.
    You have "Enable" and "Enable reflection" checked in the Avahi configuration.
    You do not have "Disable IPv4" checked in the Avahi configuration.
    You do not have anything defined in the "Advanced settings" section of the Avahi configuration.
    You have added rules to allow ptp packets from the clients to the HEOS device you are trying to control.
    You have restarted or disconnected/reconnected both HEOS clients and servers after changing the any of the above.

    I haven't had any luck so far and wanted to see if anyone else had success preferably without resorting to third party apps?

    I see my Denon Amp (HS2) but it only appears to be broadcasting Spotify as a connection point?

    inetscan.jpg


Log in to reply