SG-1100 reboots several times a day



  • I've had it for 3 days. Love it except for the self-rebooting several times per day. The other notable symptom is inability to connect. I'm assuming since I see the wireless AP the SG-1100 DHCP is not working. In that event I manually reboot.

    Running latest version 2.4.4-p2 with nmap, pfblockerNG-devel and out of the box with aws-wizard and ipsec-profile-wizard.

    Any ideas?


  • Netgate Administrator

    I'm sorry this got moved. Were you able to resolve this?

    If not I'd suggest opening a ticket with us at: https://go.netgate.com

    It obviously should not reboot spontaneously.

    Steve



  • I had great support from Netgate and still couldn't resolve so a return is in process. I will buy another one. My son-in-law bought one at the same time and it is operating flawlessly. Great device.



  • I have the same issue. I thought it was a bad power brick but I'll open a ticket after seeing this so thank you.



  • I was watching the terminal port during a cold boot and it was stuck in a boot loop for a few cycles. One of the status messages appeared to indicate the drive wasn't responding. Then it took and finished the boot sequence.

    One thing I noticed was no LAN/WAN on some self-boots. What I thought was no DHCP was no physical connection because the ports were dead. Cold boot was the only solution.

    I went through extensive troubleshooting with Netgate so it was a good learning experience.


  • Netgate Administrator

    uboot reports a lot at boot and some of that can look like errors if you're not ready for it. It checks for devices that are not connected and then shows that check failing but that is the expected output. It should not normally loop though.

    Steve



  • @stephenw10 I've had my SG-1100 about a week. It's been rebooting multiple times a day. Is my only option really to purchase a support contract to troubleshoot what very much appears to be a faulty product?


  • Netgate Administrator

    No, it should not do that. Please open a ticket with us. Just add your serial number.

    Steve



  • @stephenw10 Good to know. Thanks for the quick reply.



  • @doncbroyles Your new SG-1100 has a one year warranty. I contacted Netgate on their contact page and received great support.



  • I concur on the above that the support for my matter has been outstanding. I offered extra debugging time as I am eval'ing the unit for small sites with a dual wan config and their support on the matter has been excellent.



  • Following up on my issue, I just wanted to express my appreciation for the support I received. While it's a bummer to have to RMA something (for both parties), the support I got was stellar. Thanks.



  • @doncbroyles Agree... Just got an email from Netgate and they confirmed the reboot problem on my unit in their shop. An exchanged is being shipped. My son-in-law's unit has been running a couple weeks non-stop and he loves the performance.



  • Received my exchange SG-1100. Works great and has been up a couple days. Thanks Netgate.


  • Rebel Alliance Netgate Administrator

    @WanWeiLin

    Happy to hear that you are all set and resolved!



  • I just received my new SG-1100 four days ago and experienced the same issue. The unit reboots sporadically, sometimes several times an hour.

    Nothing in the system logs indicated any kind of software issue, so I attached the console cable to a nearby server so that I could capture the console output to a file and see if there were any additional messages showing up. That's when it got interesting...

    With the console cable connected, the unit now appears to be stable. It's been running 6 hours now with no issues. I'm wondering if it is a power issue. According to the product specs it does not support power over USB but perhaps having the USB cable connected is adding just a little bit of something to keep it stable.

    The unit is connected to a good quality UPS, so I know it's not a problem with the line.

    I'm going to let is run as it is for a few more days to see if it stays up. Then perhaps I'll disconnect the console cable and see if the problem starts to recur.

    -Doug


  • Netgate Administrator

    It definitely doesn't support USB power, it's not actually connected at all other than powering the serial console IC.

    Please open a ticket with us if you see this continuing. https://go.netgate.com

    Steve



  • Update: It ran flawlessly for 30 hours so I tried disconnecting the console cable. It self-rebooted 20 minutes later. Reconnected the console but now it still won't stay up for more than an hour. Netgate support has approved an RMA.

    There was an interesting entry in the boot log, possible identifying the EMMC as the culprit?

    Hit any key to stop autoboot:
    Card did not respond to voltage select!
    mmc_init: -95, time 41
    ** Bad device mmc 0 **
    Card did not respond to voltage select!
    mmc_init: -95, time 23
    ** Bad device mmc 0 **

    Starting EFI application at 05000000 ...

    Card did not respond to voltage select!
    mmc_init: -95, time 23
    -Doug


  • Netgate Administrator

    That is actually all normal output. mmc 0 there is the unpopulated uSD card I believe.
    It actually ends up booting from mmc 1:

    MMC: sdhci@d0000: 0, sdhci@d8000: 1
    ...
    Scanning disk sdhci@d8000.blk...
    Found 4 disks

    Steve



  • Having the same issue now. In my case the SG-1100 worked fine for a couple of weeks, then I noticed it started rebooting every 6-12 hours, and now it's rebooting as frequently as every 30 minutes. I do not see any indication of cause in the logs.

    I will open a ticket but wanted to mention it here.

    Thanks,

    Ryan



  • @ryan_b : Nothing special in the boot sequence ?
    (Console => Option 8 => dmesg



  • I received my replacement unit a week ago and it has been rock solid.

    Just want to add my +1 that Netgate support was awesome.

    -Doug


Log in to reply