Pfsense 2.4.4 no internet access! Help please! (Solved)



  • Hello Everyone,

    I am having problems accessing the internet from LAN side. I have a very simple setup.

    Cable Net Router (tplink) - > Pfsense - > PC

    The cablenet router uses a PPPOE connection to grant internet access to the devices on LAN. The Wan connection has a subnet of 192.168.0.x as defined on tplink router. I have configured WAN as DHCP (private ip) and lan interface as 172.22.101.1. The problem is that I am unable to access internet from LAN no matter what I do. The default allow to any rule is present. I have no other rule configured. I have a doubt that my internet connection may be restricted as internet works fine when I connect my laptop to it directly.
    I am attaching the firewall logs for reference.
    I am also attaching the configuration xml file that I backed up.

    Kindly let me know if you find any errors. Thank you in advance.0_1551730337227_config-pfSense.test-20190304171039.xml
    0_1551730361032_logs.xls

    The check mark is next to all entries in the excel file for logs except for one which has an x mark next to it.



  • Have you gone through the Connectivity guide? It should just work right out of the box.

    https://doc.pfsense.org/index.php/Connectivity_Troubleshooting



  • @KOM

    I tried those steps but it didn't work.I can't get to the internet. Did you check the logs and configuration file?



  • I tried those steps but it didn't work

    If I had a dollar every time I heard that one...

    Did you check the logs and configuration file?

    Nope. Trying to decipher a mishmash of xml isn't what I call fun.

    From Diagnostics - Ping, can you ping 8.8.8.8?



  • @kom I tried to ping 8.8.8.8 from diagnostics but it didn't work. What I found out is that the monitor IP (8.8.8.8) which I use to check the status of the default gateway is showing down. I just got to work. Let me post the screenshots for a better understanding.



  • @KOM Here are the screenshots!
    0_1551769598271_arp.JPG

    0_1551769607223_DNS info.JPG

    0_1551769618836_dns resolver logs.JPG

    0_1551769634940_dns resolver.JPG

    0_1551769643893_firewall logs.JPG

    0_1551769653633_general logs 2.JPG

    0_1551769662657_general logs.JPG

    0_1551769671575_interface and gateway.JPG

    0_1551769680674_interface assignment.JPG

    0_1551769693047_LAN 1.JPG

    0_1551769701639_LAN 2.JPG

    0_1551769795586_LAN Rules.JPG

    0_1551769814388_lan states.JPG

    0_1551769833955_logs gateway.JPG

    0_1551769843808_monitoring 1.JPG

    0_1551769856219_monitoring 2.JPG

    0_1551769875404_NAT outbound.JPG

    0_1551769901064_ping gateway(WAN).JPG

    0_1551769926961_ping lan to wan gateway.JPG

    0_1551769942115_ping lan to wan.JPG

    0_1551769953201_ping lan.JPG

    0_1551769970152_ping test.JPG

    0_1551769985257_ping wan interface.JPG

    0_1551769997983_ping wan.JPG

    0_1551770026536_routing logs.JPG

    0_1551770275501_routing.JPG

    0_1551770315072_services.JPG

    0_1551770334946_traffic graph lan.JPG

    0_1551770350470_traffic graph wan.JPG

    0_1551770367054_WAN 1.JPG

    0_1551770381338_WAN 2.JPG

    0_1551770394507_WAN Rules.JPG



  • Hmmm. You have some weirdness going on. Unbound (DNS Resolver) not being to bind to a socket, and the WAN gateway showing offline.

    Has this ever worked or is it a new installation? Whats on the WAN side, just a cable modem? If so, you should see if your ISP can flip it to bridged mode so that you're not double-NATing.



  • You said your WAN IP is a 'private IP' :
    @smrehan00 said in Pfsense 2.4.4 no internet access! Help please!:

    I have configured WAN as DHCP (private ip)

    192.168.0.x, right ?

    Now, check your first rule on the WAN interface :

    @smrehan00 said in Pfsense 2.4.4 no internet access! Help please!:

    0_1551770394507_WAN Rules.JPG

    You're blocking private networks - such as, for example 192.168.0.x.

    It's time to make a choice ^^



  • That RFC block on WAN would only affect incoming traffic to any NATs he might define. It's not going to affect outgoing LAN traffic and their replies.



  • @kom said in Pfsense 2.4.4 no internet access! Help please!:

    That RFC block on WAN would only affect incoming traffic to any NATs he might define

    Such as the third WAN firewall rule ?

    Any, I stand corrected, just checked mine, using a 192.168.10.5 WAN IP : nothing changed (could post this message).



  • A couple of observations...

    1. You're probably double-NAT'ed by using a cable modem that is already running NAT. That could potentially cause trouble, unless you know how to work around it. Like has been said above, see if you can get your cable modem put into bridge mode, that makes setting up your WAN interface a lot less trouble-free when it comes to overlapping or conflicting network address space and NAT rules.
    2. I don't think you need to set the Gateway addresses under System -> General Setup -> DNS Server Settings. In my several pfsense installs, these fields are always empty.
    3. On your LAN General Config page, you've got a /16 subnet mask. That's a pretty big range, allowing you to have 65,000 plus host machines on that network. Do you need a network that big for this project?
    4. Your WAN is using a private IP address of 192.168.0.106, normally this doesn't cause a problem, unless your ISP modem is also using the same network space somewhere in it's network settings.

    Jeff



  • @akuma1x
    @KOM

    I was able to resolve the issue.It was because of the internet connection as it was blocking dns and moreover the internet connection had asymmetric routing done.
    I tested the same scenario remotely from my UK office and it worked without a problem.



  • @akuma1x
    @KOM

    Thanks guys for your help.


Log in to reply