OpenVPN and VLAN setup with Unifi



  • Hi Folks,

    Here is my setup -
    pfsense with OpenVPN (on Nord) with all traffic landing routed via VPN.
    On the LAN side, I have a unifi switch which connects to a unifi AP which supports 2 wlan's (guest and private).

    My requirement is to route all traffic from guest network directly on to the internet.

    I have configured a VLAN on pFsense, configured firewall rule to allow all to internet and configured the DHCP server.

    on the switch, i have configured the VLAN and configured the wireless AP (as a Guest Network) and allocated the VLAN ID.

    when connected to the guest wifi, i cannot connect to the internet.

    Having spent a number of hours watching config videos on internet, i seem to have exhausted all options.

    Any tips on how to debug this and correct the config will be gracefully received.

    Thank you.


  • Galactic Empire

    @vpndude said in OpenVPN and VLAN setup with Unifi:

    when connected to the guest wifi, i cannot connect to the internet.
    Having spent a number of hours watching config videos on internet, i seem to have exhausted all options.
    Any tips on how to debug this and correct the config will be gracefully received.
    Thank you.

    Have you done your NAT outbound ?

    Have you set the gateway to route the traffic out the Nord connection ?



  • thank you for quick reply.

    i have setup the Outbound NAT so that the VLAN IP is directed to WAN. Is there any other specific config required here?

    Could you please elaborate on "gateway to route the traffic out the Nord connection".

    thanks.



  • just to be clear i have setup the Outbound NAT as

    • Interface = WAN
    • protocol = any
    • source = VLAN IP address

    everything else is as standard.



  • SOLVED thanks to another thread on this forum ..it was actually the VPN client configuration in that I had to check "Dont Pull Routes" which did the trick.

    Thank you!!


Log in to reply