PIA OpenVPN setup "Don't Pull Routes"



  • I am doing a new install of 2.4.4-RELEASE-p2 on a dell server (dedicated application).
    Installed are four nic cards (WAN,LAN,OPT1,OPT2). While setting up an OpenVPN for use with PIA
    I noticed a check box (VPN/OPenVPN/Clents/Edit) marked "Don't Pull Routes"
    implying that all interfaces would connect through the VPN if the box was unchecked.
    Since I don't want all the interfaces connecting throught the VPN, I would like to
    know the best way to have one of the interfaces connect to default.

    If it would be more practical to check the box and manually direct the interface assignment
    some other way (perhaphs by using specific rules on specific interfaces) I would
    like to know the best way to do this.

    I would appreciate any suggestions that you might have.



  • The route of an outbound traffic is handled by the filter rule which matches to that traffic and cannot be specified on interface base.
    By default, if gateway is not specified in the filter rule, the outbound traffic is sent to the default gateway.
    0_1552397740217_47270c8f-cb65-4b35-85cd-84c6da278599-grafik.png

    If the vpn server pushes the default route to you, any traffic handled by such rules is directed to the vpn server.
    The "Don't pull routes" option prohibits this behaviour.

    So if you check that option you have to state the vpn gateway in filter rules to direct traffic over the vpn.



  • Thank you for your response to my question. I have a followup related question
    listed below after successfully completing the PIA install.

    After installing PIA on OpenVPN a new gateway beyond the default gateway
    is established and this is reflected under the gateway tab (pfsense 2.4.4p2)
    system/routing/gateway.

    The new gateway is not shown on the dashboard. Like to know likely reasons
    why this is the case. Both the default WAN_DHCP and the PIA gateway's seem to be
    working fine.



  • Edit the gateways widget and add the vpn gateway:
    8b902257-8272-4f91-b88b-3a5b4bf0bf22-grafik.png



  • Thank you for your reply. When I check the widget, it only shows me the default gateway
    WAN_DHCP and does not show the openvpn gateway as a choice.


Log in to reply