Pfsense as Ivacy VPN client



  • Hi All,

    My network topology is as follows:

    BT Home Hub 192.168.1.254
    Pfsense WAN 192.168.1.2
    Pfsense LAN 192.168.10.X
    Wireless access point 192.168.10.X

    The purpose of Pfsense is purely to run a VPN client (Ivacy) to route all traffic on the .10 network via the VPN. I have had this running successfully for over a year with little issues on Pfsense 2.3.4.

    The system seems to have auto-updated to 2.4.2 and I've had some small issues so I've now updated to 2.4.4 but the issues persist. The VPN is up, web pages load, mdeia plays etc all seems good. However, if I run a speedtest (speedtest.net) the download test completes OK but the upload test fails and says it is blocked by a firewall. Likewise if I try to connect a torrent client it fails to connect.

    What is the best way to troubleshoot this issue to find the cause?

    Thanks in advance.


  • LAYER 8 Rebel Alliance

    AFAIK pfSense is never ever doing Auto-Update, you manually need to trigger.
    Very good OpenVPN as WAN guide: https://www.netgate.com/resources/videos/openvpn-as-a-wan-on-pfsense.html

    -Rico



  • Hi @DavieJG ,

    Sorry for necro-posting.

    Do you mind sharing your Ivacy VPN OpenVPN settings?

    I've been in contact with their support who provided me a guide to pfSense 2.4.4 that doesn't work. According to them there seems to be some issues with version 2.4.4 that their R&D team is trying to get sorted.

    I tried to use their OpenVPN config files for Linux as a reference but those don't work even on Linux.

    Hopefully your config can shed some light why mine is not working.

    Cheers


Log in to reply