Best setups for using TPLink EAP225v3 AP on multiple lan setup



  • Today is my first day installing and using Pfsense and I am a networking novice. so if my questions make me sound like a newbie, you know why. I had been using an Edgerouter X and a modded Asus with Merlin before that. After a lighting strike took out the Asus I went with the ERX and 3 TpLink EAP225v3 AP's. I used EdgeOS for ERX and Omada Controller for AP management. I was having an issue with intermittent one minute internet dropouts and did not like working in the command line much so I did some research and ended up building my own with a mini Qotom pc. I had 4 gb of ram handy as well as a Samsung 120gb ssd so it is up and running. I watched a few LawrenceSyst videos and decided to set up my four intel nics as follows, 0 for WAN, 1 for Lan, 2 for IOT devices, and 3 for wireless. From Pfsense box Lan goes to a TPlink 16 port rackmount unmanaged switch, IOT to a 8 port unmanaged Trendnet switch and wireless to a 8 port Tplink poe switch. I work from home, wife does also and we have a kid that does alot of gaming. Combine that with all the streaming, ip cams, nvr, iot devices. 40+ devices on internet at any given time. So after all the lengthy intro, here is one of the issues I am having, I am sure it will not be my last question but this one is giving me fits. I have wired lan up and running and my Comcast blast is doing 182d, 12u. I have not attached anything to IOT yet, but I was having issues with no wifi internet. After a few rules were added I got internet working on wifi. Problem is the Omada controller no longer works, it shows disconnected. It is installed on a desktop on the Lan. I installed EAP discovery tool on another desktop in the basement near rack and ran a wire to switch with AP's on it. They can now be found but I cannot figure how to get them to be able to be adopted back to Omada controller on main office PC two floors up. My brain is already overloaded with all the other info it took get me this far. I would appreciate some advice. I am really liking the OS for PFS and am sure I have a lot more learning to do on so many aspects.


  • Netgate Administrator

    Ok so the APs are on a different subnet to the controller. Whatever discovery protocol they are using does not work between them which is not surprising.
    The easiest thing might be to put the APs on LAN temporarily, adopt them to the controller and then mover them back. As long as they remember the controller IP and you have rules to allow the APs to reach the controller IP and port on the wifi interface that should work.

    If they don't remember you can pass the IP to them via DHCP option 138:
    https://www.tp-link.com/us/faq-1360.html

    Or you can just configure the controller IP via the EAP discovery tool:
    https://www.tp-link.com/us/faq-1359.html

    Steve