Trying to setup OpenVPN Client Connection



  • I am trying to configure Open VPN client. It worked perfectly fine on my test VM, but trying to get it done on my main physical router is not possible.

    After going through the same setup guide, I get this error.....
    ***PPPoE Password and confirmed password must match! (No area to address this)
    ***IPv4/IPv6 Configuration This interface type does not support manual address configuration on this page.
    I'd tried adding pic but won't let me (Says its spam)
    I am NOT using PPPoE in anyway so no idea why this is happening.
    I get the error : "IPv4/IPv6 Configuration This interface type does not support manual address configuration on this page."
    And all other settings are not present. I am desperate.
    (I have 6 WAN NICs and 8 LAN NICs)

    I am also getting the PPPoe error whens editing up my WAN interfaces but had a work around but setting WAN to PPPoE and creating bogus matching passwords then setting back to DHCP (all my WAN are dhcp) and that worked, but trying to setup this interface, I don't have that option to use this work around.
    I have no PPPoE anything on my router.
    Any help would be amazing.


  • LAYER 8 Rebel Alliance

    You get this error when assigning the OpenVPN virtual interface?
    Don't set any configuration there, just Enable!
    https://docs.netgate.com/pfsense/en/latest/book/openvpn/assigning-openvpn-interfaces.html

    -Rico



  • Thank you for your reply, and trust me, I would love to, but that is the issue, I can't...
    When I hit save, I get this....
    CaptureII.JPG
    And as you can see no area to edit it, that is the problem.


  • LAYER 8 Rebel Alliance

    Please try with a different browser and/or in incognito mode.

    -Rico



  • MAC address = 'admin' ????
    That's not good at all.

    I advise you to export your "Interfaces".
    Fire up Notepad++ (or comparable) and delete out the entire

    <opt11>
    .....
    .....
    </opt11>
    

    part.

    Import back in.
    Assign interface,
    Etc.



  • Thank you so much, trying Edge worked and I was ale to save the setting and finish the setup.
    P.S. for anyone reading this... this error appeared to be part of of a deeper issue so what I did was backup the configuration and rebuilt the system from scratch (Not a Reset to Factory default) as I tried that first and it didn't resolve anything, but a full re-install the os and applied the backup. This was the greatest fix and resolve other "glitches" as well.
    Thank you for your help.
    Cheers


Log in to reply