Grandstream UCM6202 with pfSense



  • Hello,

    Our offices have one ethernet port in each office so we cannot separate our VoIP phones and computers. The Grandstream UCM6202 works just fine without pfSense on the network. I followed several links in an attempt to resolve this issue, including: https://docs.netgate.com/pfsense/en/latest/nat/configuring-nat-for-voip-phones.html

    I am unable to find a working configuration based on any of the instructions or forum posts I've found. Has anyone gotten pfSense to work with a Grandstream UCM6202, and if so, what would I need to do to make it work?

    Thanks!



  • with a small NAT table.. So??



  • @chpalmer Sorry about that.. :-) I rewrote my question.



  • I have a Grandsteam phones that work just fine. Generally what your will find is that some voip providers do things their own way (trying to avoid patent infringement suits like happened to Vonage) and sometimes you have to do things to make it work.

    I make WAN rules with the destination my phones and the source my provider SIP servers. NO port forwarding!

    I make WAN rules to allow RTP to my phones. This takes a little more work to see where those servers originate from as my provider off loads the voice streams.

    It might help to talk about who your provider is and what information you have from them..



  • At my primary site here I use the SIProxd package. Its how I started and it just works so Im not changing it.

    If you do that instead of WAN rules to your devices you point the rules to your WAN address.



  • @Riverbound Hey,
    I'm using the UCM6204 with 40 phones in our hotel behind pfSense. Works flawlessly. BTW this is an IPBX so no need to use siproxd as this is effectively the proxy server for the phones. I assume all your phones are on the same network as the UCM so you can use the zeroconfig setting to connect the phones, if they are recent grandstream models to the UCM. The setting I use in the UCM config is "switch mode" under network settings. I haven't tried router mode but I don't think you want the added complexity if you are behind pfSense anyway. Be sure to use manual outbound nat in pfSense and then follow all the instructions forwarding sip and rtp settings as per pfSense online manual.



  • @ribula thanks!


Log in to reply